blob: 4936dcfd3a7a6fdc5e51b98db35a465e7d1993e7 [file] [log] [blame]
Patrick Williamsb2e6a9b2017-02-23 20:31:26 -06001SUMMARY = "U-boot boot scripts for Raspberry Pi"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
4COMPATIBLE_MACHINE = "rpi"
5
6DEPENDS = "u-boot-mkimage-native"
7
8SRC_URI = "file://boot.cmd"
9
10do_compile() {
11 mkimage -A arm -T script -C none -n "Boot script" -d "${WORKDIR}/boot.cmd" boot.scr
12}
13
14inherit deploy
15
16do_deploy() {
17 install -d ${DEPLOYDIR}
18 install -m 0644 boot.scr ${DEPLOYDIR}
19}
20
21addtask do_deploy after do_compile before do_build