Patrick Williams | d849ec7 | 2016-08-17 14:59:38 -0500 | [diff] [blame] | 1 | HOMEPAGE = "https://github.com/docker/docker-registry" |
| 2 | SUMMARY = "Registry server for Docker" |
| 3 | DESCRIPTION = "\ |
| 4 | This is the classic python docker-registry. \ |
| 5 | . \ |
| 6 | hosting/delivering of repositories and images \ |
| 7 | " |
| 8 | |
| 9 | SRCREV = "fd8c0c114985547b69088e0f1526e58bfe2ff914" |
| 10 | SRC_URI = "\ |
| 11 | git://github.com/docker/docker-registry.git \ |
| 12 | file://docker-registry.conf \ |
| 13 | file://docker-registry.service \ |
| 14 | file://config.yml \ |
| 15 | file://change_sqlalchemy_rqt.patch \ |
| 16 | " |
| 17 | |
| 18 | LICENSE = "Apache-2.0" |
| 19 | LIC_FILES_CHKSUM = "file://LICENSE;md5=35e8e5305c1b7b4a5761f9de5d44e5f4" |
| 20 | |
| 21 | S = "${WORKDIR}/git" |
| 22 | |
| 23 | PV = "0.9.1+git${SRCREV}" |
| 24 | |
| 25 | RDEPENDS_${PN} += "\ |
| 26 | docker \ |
| 27 | gunicorn (>= 19.1.1) \ |
| 28 | python-pip \ |
| 29 | python-distribute \ |
| 30 | python-m2crypto (>= 0.22.3) \ |
| 31 | python-pyyaml (>= 3.11) \ |
| 32 | python-flask (>= 0.10.1) \ |
| 33 | python-gevent (>= 1.0.1) \ |
| 34 | python-requests \ |
| 35 | python-sqlalchemy (>= 0.9.4) \ |
| 36 | python-blinker (>= 1.3) \ |
| 37 | python-backports-lzma (>= 0.0.3) \ |
| 38 | python-flask-cors (>= 1.10.3) \ |
| 39 | python-bugsnag (>= 2.0.2) \ |
| 40 | python-docker-registry-core (>= 2.0.3) \ |
| 41 | python-newrelic (>= 2.22.0.19) \ |
| 42 | python-itsdangerous (>= 0.21) \ |
| 43 | python-jinja2 (>= 2.4) \ |
| 44 | python-werkzeug (>= 0.7) \ |
| 45 | python-simplejson (>= 3.6.2) \ |
| 46 | python-redis (>= 2.10.3) \ |
| 47 | python-boto (>= 2.34.0) \ |
| 48 | python-webob \ |
| 49 | " |
| 50 | # OFFICIAL REQ: |
| 51 | # docker-registry-core>=2,<3 |
| 52 | # blinker==1.3 |
| 53 | # backports.lzma==0.0.3,!=0.0.4 |
| 54 | |
| 55 | # Flask==0.10.1 |
| 56 | # gevent==1.0.1 |
| 57 | # gunicorn==19.1.1 |
| 58 | # PyYAML==3.11 |
| 59 | # requests==2.3.0 |
| 60 | # M2Crypto==0.22.3 |
| 61 | # sqlalchemy==0.9.4 |
| 62 | # setuptools==5.8 |
| 63 | # |
| 64 | # [bugsnag] |
| 65 | # bugsnag>=2.0,<2.1 |
| 66 | # |
| 67 | # [cors] |
| 68 | # Flask-cors>=1.8,<2.0 |
| 69 | # |
| 70 | # [newrelic] |
| 71 | # newrelic>=2.22,<2.23 |
| 72 | |
| 73 | |
| 74 | inherit setuptools systemd |
| 75 | |
| 76 | SYSTEMD_PACKAGES = "${@base_contains('DISTRO_FEATURES','systemd','${PN}','',d)}" |
| 77 | SYSTEMD_SERVICE_${PN} = "${@base_contains('DISTRO_FEATURES','systemd','docker-registry.service','',d)}" |
| 78 | |
| 79 | do_install_append() { |
| 80 | mkdir -p ${D}/etc/default/ |
| 81 | cp ${WORKDIR}/docker-registry.conf ${D}/etc/default/docker-registry |
| 82 | |
| 83 | if ${@base_contains('DISTRO_FEATURES','systemd','true','false',d)}; then |
| 84 | install -d ${D}${systemd_unitdir}/system |
| 85 | install -m 644 ${WORKDIR}/docker-registry.service ${D}/${systemd_unitdir}/system |
| 86 | sed -i "s|#WORKDIR#|${PYTHON_SITEPACKAGES_DIR}/docker_registry|" ${D}/${systemd_unitdir}/system/docker-registry.service |
| 87 | fi |
| 88 | # based on config_mirror.yml - uses /var/docker-registry instead of /tmp for files |
| 89 | install ${WORKDIR}/config.yml ${D}/etc/docker-registry.yml |
| 90 | mkdir -p ${D}/var/docker-registry |
| 91 | } |
| 92 | |
| 93 | FILES_${PN} += "/etc/default /var/docker-registry /etc/ /etc/default/volatiles" |