Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Python bindings for the Cairo canvas library" |
| 2 | HOMEPAGE = "http://cairographics.org/pycairo" |
| 3 | BUGTRACKER = "http://bugs.freedesktop.org" |
| 4 | SECTION = "python-devel" |
| 5 | LICENSE = "LGPLv2.1 & MPLv1.1" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=f3713ca2c28d9312ad718520b6dc3eee \ |
| 7 | file://COPYING-LGPL-2.1;md5=fad9b3332be894bab9bc501572864b29 \ |
| 8 | file://COPYING-MPL-1.1;md5=bfe1f75d606912a4111c90743d6c7325" |
| 9 | |
| 10 | # cairo >= 1.14 |
| 11 | DEPENDS = "cairo python3" |
| 12 | |
| 13 | SRC_URI = "https://github.com/pygobject/pycairo/releases/download/v${PV}/pycairo-${PV}.tar.gz" |
| 14 | UPSTREAM_CHECK_URI = "https://github.com/pygobject/pycairo/releases/" |
| 15 | |
Andrew Geissler | 0903674 | 2021-06-25 14:25:14 -0500 | [diff] [blame] | 16 | SRC_URI[md5sum] = "fa88a28cadbfb34192fe743d32c0ee33" |
| 17 | SRC_URI[sha256sum] = "1ee72b035b21a475e1ed648e26541b04e5d7e753d75ca79de8c583b25785531b" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 18 | |
| 19 | S = "${WORKDIR}/pycairo-${PV}" |
| 20 | |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 21 | inherit meson pkgconfig python3targetconfig |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 22 | |
| 23 | CFLAGS += "-fPIC" |
| 24 | |
| 25 | BBCLASSEXTEND = "native" |
| 26 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 27 | FILES:${PN} = "${PYTHON_SITEPACKAGES_DIR}/*" |