Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 1 | SUMMARY = "High-Performance Asynchronous HTTP Client Library" |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 2 | DESCRIPTION = "The Apache Serf library is a C-based HTTP client library built upon the Apache \ |
| 3 | Portable Runtime (APR) library. It multiplexes connections, running the \ |
| 4 | read/write communication asynchronously. Memory copies and transformations are \ |
| 5 | kept to a minimum to provide high performance operation." |
Andrew Geissler | 95ac1b8 | 2021-03-31 14:34:31 -0500 | [diff] [blame] | 6 | HOMEPAGE = "http://serf.apache.org/" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 7 | SRC_URI = "${APACHE_MIRROR}/${BPN}/${BPN}-${PV}.tar.bz2 \ |
| 8 | file://norpath.patch \ |
Brad Bishop | bba38f3 | 2018-08-23 16:11:46 +0800 | [diff] [blame] | 9 | file://env.patch \ |
| 10 | file://0001-Fix-syntax-of-a-print-in-the-scons-file-to-unbreak-b.patch \ |
| 11 | file://0002-SConstruct-Fix-path-quoting-for-.def-generator.patch \ |
| 12 | file://0003-gen_def.patch \ |
| 13 | file://0004-Follow-up-to-r1811083-fix-building-with-scons-3.0.0-.patch \ |
Brad Bishop | f3fd288 | 2019-06-21 08:06:37 -0400 | [diff] [blame] | 14 | file://SConstruct.stop.creating.directories.without.sandbox-install.prefix.patch \ |
Brad Bishop | bba38f3 | 2018-08-23 16:11:46 +0800 | [diff] [blame] | 15 | " |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 16 | |
| 17 | SRC_URI[md5sum] = "370a6340ff20366ab088012cd13f2b57" |
| 18 | SRC_URI[sha256sum] = "549c2d21c577a8a9c0450facb5cca809f26591f048e466552240947bdf7a87cc" |
| 19 | |
| 20 | LICENSE = "Apache-2.0" |
| 21 | LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" |
| 22 | |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 23 | inherit scons |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 24 | |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 25 | DEPENDS += " openssl apr apr-util util-linux expat" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 26 | |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 27 | EXTRA_OESCONS = " \ |
| 28 | LIBDIR=${libdir} \ |
| 29 | --install-sandbox=${D} \ |
| 30 | CC="${CC}" \ |
| 31 | CFLAGS="${CFLAGS}" \ |
| 32 | LINKFLAGS="${LDFLAGS}" \ |
| 33 | APR=`which apr-1-config` \ |
| 34 | APU=`which apu-1-config` \ |
| 35 | OPENSSL="${STAGING_EXECPREFIXDIR}" \ |
| 36 | " |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 37 | |
Andrew Geissler | 09209ee | 2020-12-13 08:44:15 -0600 | [diff] [blame] | 38 | # scons creates non-reproducible archives |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 39 | do_install:append() { |
Andrew Geissler | 09209ee | 2020-12-13 08:44:15 -0600 | [diff] [blame] | 40 | rm ${D}/${libdir}/*.a |
| 41 | } |
| 42 | |
Andrew Geissler | b7d2861 | 2020-07-24 16:15:54 -0500 | [diff] [blame] | 43 | BBCLASSEXTEND = "native nativesdk" |