Patrick Williams | 3965356 | 2024-03-01 08:54:02 -0600 | [diff] [blame] | 1 | DESCRIPTION = "Recipe to trigger execution of all meta-filesystems ptest images." |
| 2 | HOMEPAGE = "https://www.openembedded.org/" |
| 3 | |
| 4 | LICENSE = "MIT" |
| 5 | |
| 6 | inherit features_check nopackages |
| 7 | REQUIRED_DISTRO_FEATURES = "ptest" |
| 8 | |
| 9 | require conf/include/ptest-packagelists-meta-filesystems.inc |
| 10 | |
| 11 | # Include the full set of ptests |
| 12 | PTESTS_META_FILESYSTEMS = "${PTESTS_FAST_META_FILESYSTEMS} ${PTESTS_SLOW_META_FILESYSTEMS} ${PTESTS_PROBLEMS_META_FILESYSTEMS}" |
| 13 | |
| 14 | do_testimage[noexec] = "1" |
| 15 | do_testimage[depends] = "${@' '.join(['meta-filesystems-image-ptest-'+x+':do_testimage' for x in d.getVar('PTESTS_META_FILESYSTEMS').split()])}" |
| 16 | |
| 17 | do_build[depends] = "${@' '.join(['meta-filesystems-image-ptest-'+x+':do_build' for x in d.getVar('PTESTS_META_FILESYSTEMS').split()])}" |
| 18 | |
| 19 | # normally image.bbclass would do this |
| 20 | EXCLUDE_FROM_WORLD = "1" |
| 21 | |
| 22 | python () { |
| 23 | if bb.utils.contains('IMAGE_CLASSES', 'testimage', True, False, d): |
| 24 | bb.build.addtask("do_testimage", "", "", d) |
| 25 | } |