Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | SUMMARY = "Paho MQTT - C libraries for the MQTT and MQTT-SN protocols" |
| 2 | DESCRIPTION = "Client implementation of open and standard messaging protocols for Machine-to-Machine (M2M) and Internet of Things (IoT)." |
| 3 | HOMEPAGE = "http://www.eclipse.org/paho/" |
| 4 | SECTION = "console/network" |
| 5 | LICENSE = "EPL-2.0 | EDL-1.0" |
| 6 | |
| 7 | LIC_FILES_CHKSUM = " \ |
| 8 | file://LICENSE;md5=fd3b896dadaeec3410d753ffaeadcfac \ |
| 9 | file://edl-v10;md5=3adfcc70f5aeb7a44f3f9b495aa1fbf3 \ |
| 10 | file://epl-v20;md5=d9fc0efef5228704e7f5b37f27192723 \ |
| 11 | " |
| 12 | |
| 13 | SRC_URI = "git://github.com/eclipse/paho.mqtt.c;protocol=https;branch=master" |
| 14 | |
| 15 | SRCREV = "07a875788d8cc6f5833b12581d6e3e349b34d719" |
| 16 | |
| 17 | DEPENDS = "openssl" |
| 18 | |
| 19 | S = "${WORKDIR}/git" |
| 20 | |
| 21 | inherit cmake |
| 22 | |
| 23 | do_configure:prepend() { |
| 24 | sed -i s:\ lib/cmake:\ ${baselib}/cmake:g ${S}/src/CMakeLists.txt |
| 25 | } |
| 26 | |
| 27 | do_install:append() { |
| 28 | # paho-mqtt installes some thing that we don't want. |
| 29 | rm -rf ${D}${prefix}/samples |
| 30 | find ${D}${prefix} -maxdepth 1 -type f -delete |
| 31 | } |
| 32 | |
| 33 | EXTRA_OECMAKE = "-DPAHO_WITH_SSL=ON -DPAHO_ENABLE_TESTING=OFF -DPAHO_HIGH_PERFORMANCE=ON" |