blob: 64210ade53e1c170e107d2b51bb3d5a4b098cff6 [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "Python parsing module"
2DESCRIPTION = "The pyparsing module is an alternative approach to creating \
3and executing simple grammars, vs. the traditional lex/yacc approach, or \
4the use of regular expressions. The pyparsing module provides a library of \
5classes that client code uses to construct the grammar directly in Python \
6code."
7HOMEPAGE = "https://github.com/pyparsing/pyparsing/"
8BUGTRACKER = "https://github.com/pyparsing/pyparsing/issues"
9
10LICENSE = "MIT"
11LIC_FILES_CHKSUM = "file://LICENSE;md5=657a566233888513e1f07ba13e2f47f1"
12
Patrick Williams44b3caf2024-04-12 16:51:14 -050013SRC_URI[sha256sum] = "a1bac0ce561155ecc3ed78ca94d3c9378656ad4c94c1270de543f621420f94ad"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000014
15UPSTREAM_CHECK_REGEX = "pyparsing-(?P<pver>.*)\.tar"
16
Patrick Williams03907ee2022-05-01 06:28:52 -050017inherit pypi python_flit_core
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000018
19RDEPENDS:${PN} += " \
Patrick Williams73bd93f2024-02-20 08:07:48 -060020 python3-datetime \
21 python3-debugger \
22 python3-html \
23 python3-json \
24 python3-netclient \
25 python3-pprint \
26 python3-stringold \
27 python3-threading \
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000028"
29
30BBCLASSEXTEND = "native nativesdk"