blob: 9d08e7acc41b6672e0a877218419b368316033b2 [file] [log] [blame]
Andrew Geisslerc5535c92023-01-27 16:10:19 -06001SUMMARY = "A low-level library for calling build-backends in pyproject.toml-based projects"
2HOMEPAGE = "https://github.com/pypa/pyproject-hooks"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=aad69c93f605003e3342b174d9b0708c"
5
6SRC_URI[sha256sum] = "f271b298b97f5955d53fb12b72c1fb1948c22c1a6b70b315c54cedaca0264ef5"
7
8inherit pypi python_flit_core
9
10PYPI_PACKAGE = "pyproject_hooks"
11
12BBCLASSEXTEND = "native nativesdk"
13
14# Bootstrap the native build
15DEPENDS:remove:class-native = "python3-build-native"
16
Patrick Williamse760df82023-05-26 11:10:49 -050017RDEPENDS:${PN} += " \
18 python3-io \
19 python3-json \
20"
Patrick Williams8e7b46e2023-05-01 14:19:06 -050021
Andrew Geisslerc5535c92023-01-27 16:10:19 -060022do_compile:class-native () {
23 python_flit_core_do_manual_build
24}
Patrick Williamsda295312023-12-05 16:48:56 -060025
26UPSTREAM_CHECK_PYPI_PACKAGE = "${PYPI_PACKAGE}"