Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 1 | SUMMARY = "PEP 621 metadata parsing" |
| 2 | DESCRIPTION = "Dataclass for PEP 621 metadata with support for core \ |
| 3 | metadata generation \ |
| 4 | \ |
| 5 | This project does not implement the parsing of pyproject.toml containing \ |
| 6 | PEP 621 metadata.\ |
| 7 | \ |
| 8 | Instead, given a Python data structure representing PEP 621 metadata \ |
| 9 | (already parsed), it will validate this input and generate a \ |
| 10 | PEP 643-compliant metadata file (e.g. PKG-INFO)." |
| 11 | HOMEPAGE = "https://github.com/FFY00/python-pyproject-metadata" |
| 12 | LICENSE = "MIT" |
| 13 | LIC_FILES_CHKSUM = "file://LICENSE;md5=310439af287b0fb4780b2ad6907c256c" |
| 14 | |
| 15 | PYPI_PACKAGE = "pyproject-metadata" |
| 16 | |
| 17 | inherit pypi python_setuptools_build_meta |
| 18 | |
| 19 | SRC_URI[sha256sum] = "0a94f18b108b9b21f3a26a3d541f056c34edcb17dc872a144a15618fed7aef67" |
| 20 | |
| 21 | RDEPENDS:${PN} += " \ |
| 22 | python3-logging \ |
| 23 | python3-packaging \ |
| 24 | python3-profile \ |
| 25 | " |
| 26 | |
| 27 | BBCLASSEXTEND = "native nativesdk" |