Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 1 | SUMMARY = "nl80211 based CLI configuration utility for wireless devices" |
| 2 | DESCRIPTION = "iw is a new nl80211 based CLI configuration utility for \ |
| 3 | wireless devices. It supports almost all new drivers that have been added \ |
| 4 | to the kernel recently. " |
| 5 | HOMEPAGE = "http://wireless.kernel.org/en/users/Documentation/iw" |
| 6 | SECTION = "base" |
| 7 | LICENSE = "BSD" |
| 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=878618a5c4af25e9b93ef0be1a93f774" |
| 9 | |
| 10 | DEPENDS = "libnl" |
| 11 | |
| 12 | SRC_URI = "http://www.kernel.org/pub/software/network/iw/${BP}.tar.gz \ |
| 13 | file://0001-iw-version.sh-don-t-use-git-describe-for-versioning.patch \ |
| 14 | file://separate-objdir.patch \ |
| 15 | " |
| 16 | |
| 17 | SRC_URI[md5sum] = "a0a17ab1b20132c716bba9a4f9974ba6" |
| 18 | SRC_URI[sha256sum] = "36fc7592dde7bec934df83cd53ef1f2c08ceec5cd58d07eb8f71cc6e8464013c" |
| 19 | |
| 20 | inherit pkgconfig |
| 21 | |
| 22 | EXTRA_OEMAKE = "\ |
| 23 | -f '${S}/Makefile' \ |
| 24 | \ |
| 25 | 'PREFIX=${prefix}' \ |
| 26 | 'SBINDIR=${sbindir}' \ |
| 27 | 'MANDIR=${mandir}' \ |
| 28 | " |
| 29 | B = "${WORKDIR}/build" |
| 30 | |
| 31 | do_install() { |
| 32 | oe_runmake 'DESTDIR=${D}' install |
| 33 | } |