blob: 45ff50d6b675c25d6d4a2b6aac3b967b086b2f83 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Initramfs image for kexecboot kernel"
2DESCRIPTION = "This image provides kexecboot (linux as bootloader) and helpers."
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
5
6IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}"
7
8# avoid circular dependencies
9EXTRA_IMAGEDEPENDS = ""
10
11# We really need just kexecboot, kexec and ubiattach
12IMAGE_INSTALL = "kexecboot kexec mtd-utils-ubifs"
13
14# Do not pollute the initrd image with rootfs features
15IMAGE_FEATURES = ""
16
17IMAGE_LINGUAS = ""
18
19FEED_DEPLOYDIR_BASE_URI = ""
20LDCONFIGDEPEND = ""
21
22IMAGE_ROOTFS_EXTRA_SPACE = "0"
23
24inherit image