Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame^] | 1 | SUMMARY = "Initramfs image for kexecboot kernel" |
| 2 | DESCRIPTION = "This image provides kexecboot (linux as bootloader) and helpers." |
| 3 | LICENSE = "MIT" |
| 4 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420" |
| 5 | |
| 6 | IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}" |
| 7 | |
| 8 | # avoid circular dependencies |
| 9 | EXTRA_IMAGEDEPENDS = "" |
| 10 | |
| 11 | # We really need just kexecboot, kexec and ubiattach |
| 12 | IMAGE_INSTALL = "kexecboot kexec mtd-utils-ubifs" |
| 13 | |
| 14 | # Do not pollute the initrd image with rootfs features |
| 15 | IMAGE_FEATURES = "" |
| 16 | |
| 17 | IMAGE_LINGUAS = "" |
| 18 | |
| 19 | FEED_DEPLOYDIR_BASE_URI = "" |
| 20 | LDCONFIGDEPEND = "" |
| 21 | |
| 22 | IMAGE_ROOTFS_EXTRA_SPACE = "0" |
| 23 | |
| 24 | inherit image |