blob: f1f5a7e8e03dd66f6c8b098338fc5edaa8587044 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Provides support for the Tag Image File Format (TIFF)"
2LICENSE = "BSD-2-Clause"
3LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=34da3db46fab7501992f9615d7e158cf"
4HOMEPAGE = "http://www.remotesensing.org/libtiff/"
5
6SRC_URI = "ftp://ftp.remotesensing.org/pub/libtiff/tiff-${PV}.tar.gz \
7 file://libtool2.patch \
Patrick Williamsf1e5d692016-03-30 15:21:19 -05008 file://CVE-2015-8781.patch \
9 file://CVE-2015-8784.patch \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050010 "
11
12SRC_URI[md5sum] = "9aee7107408a128c0c7b24286c0db900"
13SRC_URI[sha256sum] = "8cb1d90c96f61cdfc0bcf036acc251c9dbe6320334da941c7a83cfe1576ef890"
14
15inherit autotools
16
17CACHED_CONFIGUREVARS = "ax_cv_check_gl_libgl=no"
18
19PACKAGECONFIG ?= "cxx jpeg zlib lzma \
20 strip-chopping extrasample-as-alpha check-ycbcr-subsampling"
21
22PACKAGECONFIG[cxx] = "--enable-cxx,--disable-cxx,,"
23PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg,"
24PACKAGECONFIG[zlib] = "--enable-zlib,--disable-zlib,zlib,"
25PACKAGECONFIG[lzma] = "--enable-lzma,--disable-lzma,xz,"
26
27# Convert single-strip uncompressed images to multiple strips of specified
28# size (default: 8192) to reduce memory usage
29PACKAGECONFIG[strip-chopping] = "--enable-strip-chopping,--disable-strip-chopping,,"
30
31# Treat a fourth sample with no EXTRASAMPLE_ value as being ASSOCALPHA
32PACKAGECONFIG[extrasample-as-alpha] = "--enable-extrasample-as-alpha,--disable-extrasample-as-alpha,,"
33
34# Control picking up YCbCr subsample info. Disable to support files lacking
35# the tag
36PACKAGECONFIG[check-ycbcr-subsampling] = "--enable-check-ycbcr-subsampling,--disable-check-ycbcr-subsampling,,"
37
38# Support a mechanism allowing reading large strips (usually one strip files)
39# in chunks when using TIFFReadScanline. Experimental 4.0+ feature
40PACKAGECONFIG[chunky-strip-read] = "--enable-chunky-strip-read,--disable-chunky-strip-read,,"
41
42PACKAGES =+ "tiffxx tiff-utils"
43FILES_tiffxx = "${libdir}/libtiffxx.so.*"
44FILES_tiff-utils = "${bindir}/*"
45
46BBCLASSEXTEND = "native"