Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "WebP is an image format designed for the Web" |
| 2 | DESCRIPTION = "WebP is a method of lossy and lossless compression that can be \ |
| 3 | used on a large variety of photographic, translucent and \ |
| 4 | graphical images found on the web. The degree of lossy \ |
| 5 | compression is adjustable so a user can choose the trade-off \ |
| 6 | between file size and image quality. WebP typically achieves \ |
| 7 | an average of 30% more compression than JPEG and JPEG 2000, \ |
| 8 | without loss of image quality." |
| 9 | HOMEPAGE = "https://developers.google.com/speed/webp/" |
| 10 | SECTION = "libs" |
| 11 | |
| 12 | LICENSE = "BSD-3-Clause" |
| 13 | LIC_FILES_CHKSUM = "file://COPYING;md5=6e8dee932c26f2dab503abf70c96d8bb \ |
| 14 | file://PATENTS;md5=c6926d0cb07d296f886ab6e0cc5a85b7" |
| 15 | |
| 16 | SRC_URI = "http://downloads.webmproject.org/releases/webp/${BP}.tar.gz" |
Andrew Geissler | 9b4d8b0 | 2021-02-19 12:26:16 -0600 | [diff] [blame] | 17 | SRC_URI[sha256sum] = "2fc8bbde9f97f2ab403c0224fb9ca62b2e6852cbc519e91ceaa7c153ffd88a0c" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 18 | |
| 19 | UPSTREAM_CHECK_URI = "http://downloads.webmproject.org/releases/webp/index.html" |
| 20 | |
| 21 | EXTRA_OECONF = " \ |
| 22 | --disable-wic \ |
| 23 | --enable-libwebpmux \ |
| 24 | --enable-libwebpdemux \ |
| 25 | --enable-threading \ |
| 26 | " |
| 27 | |
| 28 | # Do not trust configure to determine if neon is available. |
| 29 | # |
| 30 | EXTRA_OECONF_ARM = " \ |
| 31 | ${@bb.utils.contains("TUNE_FEATURES","neon","--enable-neon","--disable-neon",d)} \ |
| 32 | " |
| 33 | EXTRA_OECONF_append_arm = " ${EXTRA_OECONF_ARM}" |
| 34 | EXTRA_OECONF_append_armeb = " ${EXTRA_OECONF_ARM}" |
| 35 | |
| 36 | inherit autotools lib_package |
| 37 | |
| 38 | PACKAGECONFIG ??= "" |
| 39 | |
| 40 | # libwebpdecoder is a subset of libwebp, don't build it unless requested |
| 41 | PACKAGECONFIG[decoder] = "--enable-libwebpdecoder,--disable-libwebpdecoder" |
| 42 | |
| 43 | # Apply for examples programs: cwebp and dwebp |
| 44 | PACKAGECONFIG[gif] = "--enable-gif,--disable-gif,giflib" |
| 45 | PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg" |
| 46 | PACKAGECONFIG[png] = "--enable-png,--disable-png,,libpng" |
| 47 | PACKAGECONFIG[tiff] = "--enable-tiff,--disable-tiff,tiff" |
| 48 | |
| 49 | # Apply only for example program vwebp |
| 50 | PACKAGECONFIG[gl] = "--enable-gl,--disable-gl,mesa-glut" |
| 51 | |
| 52 | PACKAGES =+ "${PN}-gif2webp" |
| 53 | |
| 54 | DESCRIPTION_${PN}-gif2webp = "Simple tool to convert animated GIFs to WebP" |
| 55 | FILES_${PN}-gif2webp = "${bindir}/gif2webp" |