blob: e4e3c4998824315902aa658d59c76650970c6a81 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "httplib2 caching for requests"
2HOMEPAGE = "https://pypi.org/project/CacheControl/"
3LICENSE = "Apache-2.0"
Patrick Williamsb542dec2023-06-09 01:26:37 -05004LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=12;endline=12;md5=e2fd6ddcf506e08972d5ba4b93c0022e"
Andrew Geissler595f6302022-01-24 19:11:47 +00005
6# On PyPi, this is "CacheControl", rather than "cachecontrol", so we need to
7# override PYPI_PACKAGE so fetch succeeds.
8PYPI_PACKAGE = "CacheControl"
9
Patrick Williamsb542dec2023-06-09 01:26:37 -050010SRC_URI[sha256sum] = "fd3fd2cb0ca66b9a6c1d56cc9709e7e49c63dbd19b1b1bcbd8d3f94cedfe8ce5"
Andrew Geissler595f6302022-01-24 19:11:47 +000011
12inherit pypi setuptools3
13
14RDEPENDS:${PN} += "\
15 python3-crypt \
16 python3-datetime \
17 python3-email \
18 python3-lockfile \
19 python3-json \
20 python3-logging \
21 python3-msgpack \
22 python3-netclient \
23 python3-pickle \
24 python3-requests \
25 python3-urllib3 \
26 python3-mmap \
27"
28
29BBCLASSEXTEND = "native nativesdk"