blob: f2d8bfe44be26e6ccbf4d7be2d705459f20e57cc [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001DESCRIPTION = "The leading native Python SSHv2 protocol library."
2HOMEPAGE = "https://github.com/paramiko/paramiko/"
3LICENSE = "LGPL-2.1-only"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=fd0120fc2e9f841c73ac707a30389af5"
5
Patrick Williamsb542dec2023-06-09 01:26:37 -05006SRC_URI[sha256sum] = "93cdce625a8a1dc12204439d45033f3261bdb2c201648cfcdc06f9fd0f94ec29"
Andrew Geissler9aee5002022-03-30 16:27:02 +00007
8PYPI_PACKAGE = "paramiko"
9
10inherit pypi setuptools3
11
12CLEANBROKEN = "1"
13
14RDEPENDS:${PN} += "\
15 ${PYTHON_PN}-bcrypt \
16 ${PYTHON_PN}-cryptography \
17 ${PYTHON_PN}-pynacl \
18 ${PYTHON_PN}-unixadmin \
19"