blob: 94c1b53c94a48f542325e152646ffd3238eefa3b [file] [log] [blame]
Andrew Geisslerc87764f2020-06-27 00:16:32 -05001SUMMARY = "Parse strings using a specification based on the Python format() syntax"
2HOMEPAGE = "https://github.com/r1chardj0n3s/parse"
3LICENSE = "MIT"
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -05004LIC_FILES_CHKSUM = "file://LICENSE;md5=8ab458ad281b60e6f1b39b3feafbfc05"
Andrew Geisslerc87764f2020-06-27 00:16:32 -05005
Andrew Geisslereef63862021-01-29 15:58:13 -06006SRC_URI[sha256sum] = "9ff82852bcb65d139813e2a5197627a94966245c897796760a3a2a8eb66f020b"
Andrew Geisslerc87764f2020-06-27 00:16:32 -05007
8inherit pypi setuptools3 ptest
9
Patrick Williams213cb262021-08-07 19:21:33 -050010RDEPENDS:${PN} += "\
Patrick Williamsb542dec2023-06-09 01:26:37 -050011 python3-datetime \
12 python3-logging \
13 python3-numbers \
14"
Andrew Geisslerc87764f2020-06-27 00:16:32 -050015
16SRC_URI += " \
Patrick Williamsb542dec2023-06-09 01:26:37 -050017 file://run-ptest \
Andrew Geisslerc87764f2020-06-27 00:16:32 -050018"
19
Patrick Williams213cb262021-08-07 19:21:33 -050020RDEPENDS:${PN}-ptest += " \
Patrick Williamsb542dec2023-06-09 01:26:37 -050021 python3-pytest \
Andrew Geisslerc87764f2020-06-27 00:16:32 -050022"
23
24do_install_ptest() {
Patrick Williamsb542dec2023-06-09 01:26:37 -050025 cp -f ${S}/test_parse.py ${D}${PTEST_PATH}/
Andrew Geisslerc87764f2020-06-27 00:16:32 -050026}