Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "ACPICA tools for the development and debug of ACPI tables" |
| 2 | DESCRIPTION = "The ACPI Component Architecture (ACPICA) project provides an \ |
| 3 | OS-independent reference implementation of the Advanced Configuration and \ |
| 4 | Power Interface Specification (ACPI). ACPICA code contains those portions of \ |
| 5 | ACPI meant to be directly integrated into the host OS as a kernel-resident \ |
| 6 | subsystem, and a small set of tools to assist in developing and debugging \ |
| 7 | ACPI tables." |
| 8 | |
| 9 | HOMEPAGE = "http://www.acpica.org/" |
| 10 | SECTION = "console/tools" |
| 11 | |
Andrew Geissler | 5199d83 | 2021-09-24 16:47:35 -0500 | [diff] [blame] | 12 | LICENSE = "Intel | BSD-3-Clause | GPLv2" |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 13 | LIC_FILES_CHKSUM = "file://source/compiler/aslcompile.c;beginline=7;endline=150;md5=c33ce358fdcd142684e41e336b7992e8" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 14 | |
| 15 | COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux" |
| 16 | |
| 17 | DEPENDS = "m4-native flex-native bison-native" |
| 18 | |
| 19 | SRC_URI = "https://acpica.org/sites/acpica/files/acpica-unix-${PV}.tar.gz" |
Andrew Geissler | d159c7f | 2021-09-02 21:05:58 -0500 | [diff] [blame] | 20 | SRC_URI[sha256sum] = "4a0c14d5148666612aa0555c5179eaa86230602394fd1bc3d16b506fcf49b5de" |
Andrew Geissler | 1e34c2d | 2020-05-29 16:02:59 -0500 | [diff] [blame] | 21 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 22 | UPSTREAM_CHECK_URI = "https://acpica.org/downloads" |
| 23 | |
| 24 | S = "${WORKDIR}/acpica-unix-${PV}" |
| 25 | |
| 26 | inherit update-alternatives |
| 27 | |
| 28 | ALTERNATIVE_PRIORITY = "100" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 29 | ALTERNATIVE:${PN} = "acpixtract acpidump" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 30 | |
| 31 | EXTRA_OEMAKE = "CC='${CC}' \ |
| 32 | OPT_CFLAGS=-Wall \ |
| 33 | DESTDIR=${D} \ |
| 34 | PREFIX=${prefix} \ |
| 35 | INSTALLDIR=${bindir} \ |
| 36 | INSTALLFLAGS= \ |
Andrew Geissler | 9b4d8b0 | 2021-02-19 12:26:16 -0600 | [diff] [blame] | 37 | YACC=bison \ |
| 38 | YFLAGS='-y --file-prefix-map=${WORKDIR}=/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}' \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 39 | " |
| 40 | |
| 41 | do_install() { |
| 42 | oe_runmake install |
| 43 | } |
| 44 | |
| 45 | # iasl*.bb is a subset of this recipe, so RREPLACE it |
| 46 | PROVIDES = "iasl" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 47 | RPROVIDES:${PN} += "iasl" |
| 48 | RREPLACES:${PN} += "iasl" |
| 49 | RCONFLICTS:${PN} += "iasl" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 50 | |
| 51 | BBCLASSEXTEND = "native" |