blob: 53771e2a279b9d80fd2650312cdaa94cdb5a93b1 [file] [log] [blame]
Andrew Geissler8f840682023-07-21 09:09:43 -05001# SPDX-License-Identifier: MIT
2# Copyright (C) 2023 iris-GmbH infrared & intelligent sensors
3
4SUMMARY = "A tool for creating isolated virtual python environments."
5HOMEPAGE = "https://github.com/pypa/virtualenv"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=0ce089158cf60a8ab6abb452b6405538"
8
9SRC_URI[sha256sum] = "8ff19a38c1021c742148edc4f81cb43d7f8c6816d2ede2ab72af5b84c749ade1"
10
11BBCLASSEXTEND = "native nativesdk"
12inherit pypi python_hatchling
13
14DEPENDS += "\
15 ${PYTHON_PN}-hatch-vcs-native \
16"
17
18RDEPENDS:${PN} += " \
19 ${PYTHON_PN}-distlib \
20 ${PYTHON_PN}-filelock \
21 ${PYTHON_PN}-platformdirs \
22"