Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | SUMMARY = "Python WBEM Client and Provider Interface" |
| 2 | DESCRIPTION = "\ |
| 3 | A Python library for making CIM (Common Information Model) operations over \ |
| 4 | HTTP using the WBEM CIM-XML protocol. It is based on the idea that a good \ |
| 5 | WBEM client should be easy to use and not necessarily require a large amount \ |
| 6 | of programming knowledge. It is suitable for a large range of tasks from \ |
| 7 | simply poking around to writing web and GUI applications. \ |
| 8 | \ |
| 9 | WBEM, or Web Based Enterprise Management is a manageability protocol, like \ |
| 10 | SNMP, standardised by the Distributed Management Task Force (DMTF) available \ |
| 11 | at http://www.dmtf.org/standards/wbem. \ |
| 12 | \ |
| 13 | It also provides a Python provider interface, and is the fastest and easiest \ |
| 14 | way to write providers on the planet." |
| 15 | HOMEPAGE = "http://pywbem.github.io" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 16 | LICENSE = "LGPL-2.1-only" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 17 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=fbc093901857fcd118f065f900982c24" |
| 18 | |
Andrew Geissler | fc113ea | 2023-03-31 09:59:46 -0500 | [diff] [blame] | 19 | SRC_URI[sha256sum] = "abdbd6ce08b6c597cdd6c7730e6b49a842d913f2f6b3cc62b585c58ec3ee7945" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 20 | |
| 21 | inherit pypi setuptools3 update-alternatives |
| 22 | |
| 23 | DEPENDS += " \ |
Patrick Williams | 520786c | 2023-06-25 16:20:36 -0500 | [diff] [blame] | 24 | python3-ply-native \ |
| 25 | python3-pyyaml-native \ |
| 26 | python3-six-native \ |
| 27 | python3-wheel-native \ |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 28 | " |
| 29 | |
Patrick Williams | 520786c | 2023-06-25 16:20:36 -0500 | [diff] [blame] | 30 | RDEPENDS:${PN} += "\ |
| 31 | python3-datetime \ |
| 32 | python3-io \ |
| 33 | python3-logging \ |
| 34 | python3-netclient \ |
| 35 | python3-nocasedict \ |
| 36 | python3-nocaselist \ |
| 37 | python3-ply \ |
| 38 | python3-pyyaml \ |
| 39 | python3-requests \ |
| 40 | python3-six \ |
| 41 | python3-stringold \ |
| 42 | python3-threading \ |
| 43 | python3-unixadmin \ |
| 44 | python3-xml \ |
| 45 | python3-yamlloader \ |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 46 | " |
| 47 | |
| 48 | ALTERNATIVE:${PN} = "mof_compiler" |
| 49 | ALTERNATIVE_TARGET[mof_compiler] = "${bindir}/mof_compiler" |
| 50 | |
| 51 | ALTERNATIVE_PRIORITY = "60" |
| 52 | |
| 53 | BBCLASSEXTEND = "native" |