Patrick Williams | 169d7bc | 2024-01-05 11:33:25 -0600 | [diff] [blame] | 1 | SUMMARY = "Jpeg 2000 implementation" |
| 2 | HOMEPAGE = "https://jasper-software.github.io/jasper/" |
| 3 | LICENSE = "MIT" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=a80440d1d8f17d041c71c7271d6e06eb" |
| 5 | |
| 6 | SRC_URI = "git://github.com/jasper-software/jasper.git;protocol=https;branch=master" |
| 7 | SRCREV = "917f7708b755d8434f70618108c1a76f1b6a0a82" |
| 8 | |
| 9 | CVE_STATUS[CVE-2015-8751] = "fixed-version: The CPE in the NVD database doesn't reflect correctly the vulnerable versions." |
| 10 | |
| 11 | S = "${WORKDIR}/git" |
| 12 | |
| 13 | inherit cmake multilib_header |
| 14 | |
| 15 | do_configure:prepend() { |
| 16 | JAS_STDC_VERSION="$(echo __STDC_VERSION__ | ${CPP} -E -P -)" |
| 17 | } |
| 18 | |
| 19 | EXTRA_OECMAKE:append = " -DJAS_STDC_VERSION=${JAS_STDC_VERSION}" |
| 20 | |
| 21 | PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'opengl x11', 'opengl', '', d)} \ |
| 22 | jpeg" |
| 23 | |
| 24 | PACKAGECONFIG[jpeg] = "-DJAS_ENABLE_LIBJPEG=ON,-DJAS_ENABLE_LIBJPEG=OFF,jpeg," |
| 25 | PACKAGECONFIG[opengl] = "-DJAS_ENABLE_OPENGL=ON,-DJAS_ENABLE_OPENGL=OFF,freeglut," |
| 26 | |
| 27 | do_install:append() { |
| 28 | chrpath -d ${D}${bindir}/jasper |
| 29 | chrpath -d ${D}${bindir}/imginfo |
| 30 | chrpath -d ${D}${bindir}/imgcmp |
| 31 | chrpath -d ${D}${libdir}/libjasper.so.* |
| 32 | oe_multilib_header jasper/jas_config.h |
| 33 | } |
| 34 | |