Patrick Williams | 3965356 | 2024-03-01 08:54:02 -0600 | [diff] [blame] | 1 | DESCRIPTION = "CAN BUS tools in Python 3." |
| 2 | HOMEPAGE = "https://github.com/eerimoq/cantools" |
| 3 | LICENSE = "MIT" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=d9aa4ec07de78abae21c490c9ffe61bd" |
| 5 | |
| 6 | SRC_URI[sha256sum] = "6e8e918b6671a62a9f3990546ece5623e1deb71defb1cef85a9955ac301da99e" |
| 7 | |
| 8 | PYPI_PACKAGE = "cantools" |
| 9 | |
| 10 | inherit pypi python_poetry_core |
| 11 | |
| 12 | DEPENDS += "python3-setuptools-scm-native" |
| 13 | |
| 14 | RDEPENDS:${PN} += "\ |
| 15 | python3-can \ |
| 16 | python3-bitstruct \ |
| 17 | python3-core \ |
| 18 | python3-textparser \ |
| 19 | python3-typing-extensions \ |
| 20 | python3-diskcache \ |
| 21 | python3-asyncio \ |
| 22 | " |
| 23 | |
| 24 | CLEANBROKEN = "1" |