Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 1 | SUMMARY = "A next generation HTTP client for Python." |
| 2 | SECTION = "devel/python" |
| 3 | LICENSE = "BSD-3-Clause" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE.md;md5=c624803bdf6fc1c4ce39f5ae11d7bd05" |
| 5 | |
| 6 | inherit pypi python_hatchling |
| 7 | |
| 8 | SRC_URI[sha256sum] = "451b55c30d5185ea6b23c2c793abf9bb237d2a7dfb901ced6ff69ad37ec1dfaf" |
| 9 | |
| 10 | DEPENDS += "\ |
| 11 | python3-hatch-fancy-pypi-readme-native \ |
| 12 | " |
| 13 | |
| 14 | PACKAGECONFIG ??= "" |
| 15 | PACKAGECONFIG[brotli] = ",,,python3-brotli" |
| 16 | PACKAGECONFIG[http2] = ",,,python3-h2" |
| 17 | PACKAGECONFIG[socks] = ",,,python3-socksio" |
| 18 | |
| 19 | RDEPENDS:${PN} += "\ |
| 20 | python3-anyio \ |
| 21 | python3-certifi \ |
| 22 | python3-httpcore \ |
| 23 | python3-idna \ |
| 24 | python3-sniffio \ |
| 25 | " |
| 26 | |
| 27 | PACKAGES += "\ |
| 28 | ${PN}-cli \ |
| 29 | " |
| 30 | |
| 31 | RDEPENDS:${PN}-cli += "\ |
| 32 | ${PN} \ |
| 33 | python3-click \ |
| 34 | python3-pygments \ |
| 35 | python3-rich \ |
| 36 | " |
| 37 | |
| 38 | FILES:${PN} = "\ |
Patrick Williams | 3965356 | 2024-03-01 08:54:02 -0600 | [diff] [blame] | 39 | ${libdir}/${PYTHON_DIR} \ |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 40 | " |
| 41 | |
| 42 | FILES:${PN}-cli = "\ |
Patrick Williams | 3965356 | 2024-03-01 08:54:02 -0600 | [diff] [blame] | 43 | ${bindir}/httpx \ |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 44 | " |