Patrick Williams | b58112e | 2024-03-07 11:16:36 -0600 | [diff] [blame^] | 1 | SUMMARY = "Simplified object serialization in python" |
| 2 | DESCRIPTION = "Marshmallow is an ORM/ODM/framework-agnostic library for converting complex datatypes, such as objects, to and from native Python datatypes." |
| 3 | HOMEPAGE = "https://github.com/marshmallow-code/marshmallow" |
| 4 | LICENSE = "MIT" |
| 5 | LIC_FILES_CHKSUM = "\ |
| 6 | file://LICENSE;md5=27586b20700d7544c06933afe56f7df4 \ |
| 7 | file://docs/license.rst;md5=13da439ad060419fb7cf364523017cfb" |
| 8 | |
| 9 | SRC_URI[sha256sum] = "4e65e9e0d80fc9e609574b9983cf32579f305c718afb30d7233ab818571768c3" |
| 10 | |
| 11 | inherit python_flit_core pypi ptest |
| 12 | |
| 13 | PIP_INSTALL_PACKAGE = "marshmallow" |
| 14 | |
| 15 | SRC_URI += " \ |
| 16 | file://run-ptest \ |
| 17 | " |
| 18 | |
| 19 | RDEPENDS:${PN}-ptest += " \ |
| 20 | python3-pytest \ |
| 21 | python3-pytz \ |
| 22 | python3-simplejson \ |
| 23 | python3-unittest-automake-output \ |
| 24 | " |
| 25 | |
| 26 | do_install_ptest() { |
| 27 | install -d ${D}${PTEST_PATH}/tests |
| 28 | rm -rf ${S}/tests/mypy_test_cases |
| 29 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| 30 | } |
| 31 | |
| 32 | RDEPENDS:${PN} += " \ |
| 33 | python3-compression \ |
| 34 | python3-datetime \ |
| 35 | python3-email \ |
| 36 | python3-json \ |
| 37 | python3-numbers \ |
| 38 | python3-pprint \ |
| 39 | python3-packaging \ |
| 40 | " |