blob: 7979f04c5b98222ee9c9317d54042f007eed92d6 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "SMPP library for python"
2SECTION = "devel/python"
Andrew Geissler9aee5002022-03-30 16:27:02 +00003LICENSE = "GPL-3.0-only"
Andrew Geissler595f6302022-01-24 19:11:47 +00004LIC_FILES_CHKSUM = "file://README.md;md5=8b4e2ac8cf248f7b991784f88b630852"
5
6PYPI_PACKAGE = "smpplib"
Andrew Geissler3eeda902023-05-19 10:14:02 -05007SRC_URI[sha256sum] = "5215a95b0538d26f189600e0982b31da8281f7453cd6e2862c5b21e3e1002331"
Andrew Geissler595f6302022-01-24 19:11:47 +00008
9inherit pypi setuptools3 ptest
10
11SRC_URI += " \
12 file://run-ptest \
13"
14
15RDEPENDS:${PN} += " \
Patrick Williams73bd93f2024-02-20 08:07:48 -060016 python3-logging \
17 python3-six \
Andrew Geissler595f6302022-01-24 19:11:47 +000018"
19
20RDEPENDS:${PN}-ptest += " \
Patrick Williams73bd93f2024-02-20 08:07:48 -060021 python3-mock \
22 python3-profile \
23 python3-pytest \
24 python3-unittest \
25 python3-unittest-automake-output \
Andrew Geissler595f6302022-01-24 19:11:47 +000026"
27
28do_install_ptest() {
29 install -d ${D}${PTEST_PATH}/tests
30 cp -rf ${S}/smpplib/tests/* ${D}${PTEST_PATH}/tests/
31}