blob: 6cde243fe85d5f861c93990315e05f9397e6a8e0 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001DESCRIPTION = "A portable, lightweight MessagePack serializer and deserializer written in pure Python."
2
3LICENSE = "MIT"
Patrick Williamse760df82023-05-26 11:10:49 -05004LIC_FILES_CHKSUM = "file://LICENSE;md5=17df11353545c53a2df0ce7655859306"
Andrew Geissler517393d2023-01-13 08:55:19 -06005
Patrick Williamse760df82023-05-26 11:10:49 -05006SRC_URI[sha256sum] = "b801a83d6ed75e6df41e44518b4f2a9c221dc2da4bcd5380e3a0feda520bc61a"
Andrew Geissler517393d2023-01-13 08:55:19 -06007
8inherit pypi setuptools3 ptest
9
10SRC_URI += " \
11 file://run-ptest \
12"
13
14RDEPENDS:${PN}-ptest += " \
Patrick Williams73bd93f2024-02-20 08:07:48 -060015 python3-pytest \
16 python3-unittest-automake-output \
Andrew Geissler517393d2023-01-13 08:55:19 -060017"
18
19do_install_ptest() {
20 cp -f ${S}/test_umsgpack.py ${D}${PTEST_PATH}/
21}
22
23RDEPENDS:${PN} += " \
Patrick Williams73bd93f2024-02-20 08:07:48 -060024 python3-datetime \
Andrew Geissler517393d2023-01-13 08:55:19 -060025"
26
27BBCLASSEXTEND = "native nativesdk"