Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | SUMMARY = "A Python module for decorators, wrappers and monkey patching." |
| 2 | HOMEPAGE = "http://wrapt.readthedocs.org/" |
| 3 | LICENSE = "BSD-2-Clause" |
| 4 | SECTION = "devel/python" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=dc34cbad60bc961452eb7ade801d25f7" |
| 6 | |
| 7 | SRC_URI[sha256sum] = "5f370f952971e7d17c7d1ead40e49f32345a7f7a5373571ef44d800d06b1899d" |
| 8 | |
Patrick Williams | b58112e | 2024-03-07 11:16:36 -0600 | [diff] [blame^] | 9 | inherit pypi setuptools3 ptest |
| 10 | |
| 11 | SRC_URI += " \ |
| 12 | file://run-ptest \ |
| 13 | " |
| 14 | |
| 15 | RDEPENDS:${PN}-ptest += " \ |
| 16 | python3-pytest \ |
| 17 | python3-unittest-automake-output \ |
| 18 | " |
| 19 | |
| 20 | do_install_ptest() { |
| 21 | install -d ${D}${PTEST_PATH}/tests |
| 22 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| 23 | } |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 24 | |
| 25 | RDEPENDS:${PN}:class-target += "\ |
Patrick Williams | 3965356 | 2024-03-01 08:54:02 -0600 | [diff] [blame] | 26 | python3-stringold \ |
| 27 | python3-threading \ |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 28 | " |
| 29 | |
| 30 | BBCLASSEXTEND = "native" |