blob: 056323cd39ad84e671251e3d708e39341aa38b92 [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "A Python module for decorators, wrappers and monkey patching."
2HOMEPAGE = "http://wrapt.readthedocs.org/"
3LICENSE = "BSD-2-Clause"
4SECTION = "devel/python"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=dc34cbad60bc961452eb7ade801d25f7"
6
7SRC_URI[sha256sum] = "5f370f952971e7d17c7d1ead40e49f32345a7f7a5373571ef44d800d06b1899d"
8
Patrick Williamsb58112e2024-03-07 11:16:36 -06009inherit pypi setuptools3 ptest
10
11SRC_URI += " \
12 file://run-ptest \
13"
14
15RDEPENDS:${PN}-ptest += " \
16 python3-pytest \
17 python3-unittest-automake-output \
18"
19
20do_install_ptest() {
21 install -d ${D}${PTEST_PATH}/tests
22 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
23}
Patrick Williamsac13d5f2023-11-24 18:59:46 -060024
25RDEPENDS:${PN}:class-target += "\
Patrick Williams39653562024-03-01 08:54:02 -060026 python3-stringold \
27 python3-threading \
Patrick Williamsac13d5f2023-11-24 18:59:46 -060028"
29
30BBCLASSEXTEND = "native"