blob: 7059cf76ee4a70b059ac064965d21b426de5b72f [file] [log] [blame]
Brad Bishope42b3e32020-01-15 22:08:42 -05001SUMMARY = "Utility library to parse, compare, simplify and normalize license expressions"
2HOMEPAGE = "https://github.com/nexB/license-expression"
3
4LICENSE = "Apache-2.0"
Andrew Geissler87f5cff2022-09-30 13:13:31 -05005LIC_FILES_CHKSUM = "file://apache-2.0.LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
Brad Bishope42b3e32020-01-15 22:08:42 -05006
Patrick Williams169d7bc2024-01-05 11:33:25 -06007SRC_URI[sha256sum] = "599928edd995c43fc335e0af342076144dc71cb858afa1ed9c1c30c4e81794f5"
Brad Bishope42b3e32020-01-15 22:08:42 -05008
Andrew Geissler9aee5002022-03-30 16:27:02 +00009inherit pypi ptest python_setuptools_build_meta
Brad Bishope42b3e32020-01-15 22:08:42 -050010
Patrick Williams73bd93f2024-02-20 08:07:48 -060011DEPENDS += "python3-setuptools-scm-native"
Andrew Geissler69721092021-07-23 12:57:00 -040012
Patrick Williams213cb262021-08-07 19:21:33 -050013RDEPENDS:${PN} += "\
Patrick Williams73bd93f2024-02-20 08:07:48 -060014 python3-booleanpy \
15 python3-core \
16 python3-json \
17 python3-stringold \
18 python3-logging \
Andrew Geissler69721092021-07-23 12:57:00 -040019"
Brad Bishope42b3e32020-01-15 22:08:42 -050020
21BBCLASSEXTEND = "native nativesdk"
Andrew Geissler82c905d2020-04-13 13:39:40 -050022
23SRC_URI += " \
24 file://run-ptest \
25"
26
Patrick Williams213cb262021-08-07 19:21:33 -050027RDEPENDS:${PN}-ptest += " \
Patrick Williams73bd93f2024-02-20 08:07:48 -060028 python3-pytest \
29 python3-unittest-automake-output \
Andrew Geissler82c905d2020-04-13 13:39:40 -050030"
31
32do_install_ptest() {
Andrew Geisslerd159c7f2021-09-02 21:05:58 -050033 install -d ${D}${PTEST_PATH}/tests
34 install -d ${D}${PTEST_PATH}/src
35 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
36 cp -rf ${S}/src/* ${D}${PTEST_PATH}/src/
Patrick Williams169d7bc2024-01-05 11:33:25 -060037 cp -rf ${S}/setup.cfg ${D}${PTEST_PATH}/
Andrew Geissler82c905d2020-04-13 13:39:40 -050038}