Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | SUMMARY = "Pure python rfc3986 validator" |
| 2 | HOMEPAGE = "https://github.com/naimetti/rfc3986-validator" |
| 3 | LICENSE = "MIT" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=a21b13b5a996f08f7e0b088aa38ce9c6" |
| 5 | |
| 6 | FILESEXTRAPATHS:prepend := "${THISDIR}/python-rfc3986-validator:" |
| 7 | |
| 8 | SRC_URI[md5sum] = "47f7657b790aaf6011a1ab3d86c6be95" |
| 9 | SRC_URI[sha256sum] = "3d44bde7921b3b9ec3ae4e3adca370438eccebc676456449b145d533b240d055" |
| 10 | |
| 11 | PYPI_PACKAGE = "rfc3986_validator" |
| 12 | UPSTREAM_CHECK_REGEX = "/rfc3986-validator/(?P<pver>(\d+[\.\-_]*)+)/" |
| 13 | |
| 14 | inherit pypi setuptools3 |
| 15 | |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 16 | SRC_URI += "\ |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 17 | file://0001-setup.py-move-pytest-runner-to-test_requirements.patch \ |
| 18 | " |
| 19 | |
| 20 | RDEPENDS:${PN} += "\ |
| 21 | python3-core \ |
| 22 | " |
| 23 | |
| 24 | BBCLASSEXTEND = "native nativesdk" |