Willy Tu | 5538c16 | 2021-02-10 11:44:57 -0800 | [diff] [blame] | 1 | SUMMARY = "nftables systemd wrapper" |
| 2 | DESCRIPTION = "nftables systemd wrapper" |
| 3 | PR = "r1" |
| 4 | PV = "1.0" |
| 5 | |
| 6 | LICENSE = "Apache-2.0" |
| 7 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
| 8 | |
| 9 | inherit systemd |
| 10 | |
William A. Kennington III | c20feb7 | 2021-03-08 12:31:30 -0800 | [diff] [blame] | 11 | SRC_URI += " \ |
| 12 | file://nft-configure.sh \ |
| 13 | file://nftables.service \ |
| 14 | " |
| 15 | |
Willy Tu | 4dd03ca | 2021-08-06 09:37:35 -0700 | [diff] [blame] | 16 | SYSTEMD_SERVICE:${PN} += "nftables.service" |
Willy Tu | 5538c16 | 2021-02-10 11:44:57 -0800 | [diff] [blame] | 17 | |
Willy Tu | 4dd03ca | 2021-08-06 09:37:35 -0700 | [diff] [blame] | 18 | RDEPENDS:${PN} += " \ |
William A. Kennington III | 9b16719 | 2021-03-08 11:59:56 -0800 | [diff] [blame] | 19 | bash \ |
| 20 | nftables \ |
| 21 | " |
| 22 | |
Willy Tu | 5538c16 | 2021-02-10 11:44:57 -0800 | [diff] [blame] | 23 | do_install() { |
William A. Kennington III | c20feb7 | 2021-03-08 12:31:30 -0800 | [diff] [blame] | 24 | install -d ${D}${libexecdir} |
| 25 | install -m0755 ${WORKDIR}/nft-configure.sh ${D}${libexecdir}/ |
| 26 | |
| 27 | install -d ${D}${systemd_system_unitdir} |
| 28 | install -m0644 ${WORKDIR}/nftables.service ${D}${systemd_system_unitdir}/ |
Willy Tu | 5538c16 | 2021-02-10 11:44:57 -0800 | [diff] [blame] | 29 | } |