Andrew Geissler | 84ad7c5 | 2020-06-27 00:00:16 -0500 | [diff] [blame] | 1 | SUMMARY = "Building and installing bootgen" |
| 2 | DESCRIPTION = "Building and installing bootgen, a Xilinx tool that lets you stitch binary files together and generate device boot images" |
| 3 | |
| 4 | LICENSE = "Apache-2.0" |
Andrew Geissler | 7eb438a | 2020-11-30 19:53:16 -0600 | [diff] [blame] | 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=d526b6d0807bf263b97da1da876f39b1" |
Andrew Geissler | 84ad7c5 | 2020-06-27 00:00:16 -0500 | [diff] [blame] | 6 | |
| 7 | S = "${WORKDIR}/git" |
| 8 | |
| 9 | DEPENDS += "openssl" |
| 10 | RDEPENDS_${PN} += "openssl" |
| 11 | |
| 12 | REPO ?= "git://github.com/Xilinx/bootgen.git;protocol=https" |
| 13 | BRANCH ?= "master" |
Andrew Geissler | 7eb438a | 2020-11-30 19:53:16 -0600 | [diff] [blame] | 14 | SRCREV ?= "465e32423aa6ba2d71f51c4ae0602cfeb022af08" |
Andrew Geissler | 84ad7c5 | 2020-06-27 00:00:16 -0500 | [diff] [blame] | 15 | |
| 16 | BRANCHARG = "${@['nobranch=1', 'branch=${BRANCH}'][d.getVar('BRANCH', True) != '']}" |
| 17 | SRC_URI = "${REPO};${BRANCHARG}" |
| 18 | |
| 19 | EXTRA_OEMAKE += 'CROSS_COMPILER="${CXX}" -C ${S}' |
| 20 | CXXFLAGS_append = " -std=c++0x" |
| 21 | |
| 22 | TARGET_CC_ARCH += "${LDFLAGS}" |
| 23 | |
| 24 | do_install() { |
| 25 | install -d ${D}${bindir} |
| 26 | install -Dm 0755 ${S}/bootgen ${D}${bindir} |
| 27 | } |
| 28 | |
| 29 | FILES_${PN} = "${bindir}/bootgen" |
| 30 | |
| 31 | BBCLASSEXTEND = "native nativesdk" |