Brad Bishop | 286d45c | 2018-10-02 15:21:57 -0400 | [diff] [blame] | 1 | SUMMARY = "Linux kernel module for Video Code Unit" |
| 2 | DESCRIPTION = "Out-of-tree VCU decoder, encoder and common kernel modules provider for MPSoC EV devices" |
| 3 | SECTION = "kernel/modules" |
| 4 | LICENSE = "GPLv2" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE.md;md5=eb723b61539feef013de476e68b5c50a" |
| 6 | |
| 7 | XILINX_VCU_VERSION = "1.0.0" |
Brad Bishop | 286d45c | 2018-10-02 15:21:57 -0400 | [diff] [blame] | 8 | PV = "${XILINX_VCU_VERSION}-xilinx-${XILINX_RELEASE_VERSION}+git${SRCPV}" |
| 9 | |
| 10 | S = "${WORKDIR}/git" |
| 11 | |
Andrew Geissler | 7eb438a | 2020-11-30 19:53:16 -0600 | [diff] [blame] | 12 | BRANCH ?= "release-2020.2" |
Brad Bishop | 286d45c | 2018-10-02 15:21:57 -0400 | [diff] [blame] | 13 | REPO ?= "git://github.com/xilinx/vcu-modules.git;protocol=https" |
Andrew Geissler | 7eb438a | 2020-11-30 19:53:16 -0600 | [diff] [blame] | 14 | SRCREV ?= "844d4c4292e08ad8c3f22ac78e9a937395c1db4b" |
Brad Bishop | 286d45c | 2018-10-02 15:21:57 -0400 | [diff] [blame] | 15 | |
| 16 | BRANCHARG = "${@['nobranch=1', 'branch=${BRANCH}'][d.getVar('BRANCH', True) != '']}" |
| 17 | SRC_URI = "${REPO};${BRANCHARG}" |
| 18 | |
| 19 | inherit module |
| 20 | |
| 21 | EXTRA_OEMAKE += "O=${STAGING_KERNEL_BUILDDIR}" |
| 22 | |
| 23 | RDEPENDS_${PN} = "vcu-firmware" |
| 24 | |
| 25 | COMPATIBLE_MACHINE = "^$" |
| 26 | COMPATIBLE_MACHINE_zynqmp = "zynqmp" |
| 27 | |
Andrew Geissler | 84ad7c5 | 2020-06-27 00:00:16 -0500 | [diff] [blame] | 28 | PACKAGE_ARCH = "${SOC_FAMILY_ARCH}" |
| 29 | |
| 30 | KERNEL_MODULE_AUTOLOAD += "dmaproxy" |