blob: 15cc7ac2442e3f3045442a1d97a13ed1ce8eda23 [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "Checksumming Copy on Write Filesystem utilities"
2DESCRIPTION = "Btrfs is a new copy on write filesystem for Linux aimed at \
3implementing advanced features while focusing on fault tolerance, repair and \
4easy administration. \
5This package contains utilities (mkfs, fsck, btrfsctl) used to work with \
6btrfs and an utility (btrfs-convert) to make a btrfs filesystem from an ext3."
7
8HOMEPAGE = "https://btrfs.wiki.kernel.org"
9
10LICENSE = "GPL-2.0-only & LGPL-2.1-or-later"
11LIC_FILES_CHKSUM = " \
12 file://COPYING;md5=fcb02dc552a041dee27e4b85c7396067 \
13 file://libbtrfsutil/COPYING;md5=4fbd65380cdd255951079008b364516c \
14"
15SECTION = "base"
16DEPENDS = "util-linux zlib"
17
18SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/kdave/btrfs-progs.git;branch=master;protocol=https \
19 file://0001-Add-a-possibility-to-specify-where-python-modules-ar.patch \
20 "
Patrick Williams44b3caf2024-04-12 16:51:14 -050021SRCREV = "3793e987d2b4e878410da16f33d963043d137d48"
Patrick Williamsac13d5f2023-11-24 18:59:46 -060022S = "${WORKDIR}/git"
23
24PACKAGECONFIG ??= " \
25 programs \
26 convert \
27 python \
28 crypto-builtin \
29"
Patrick Williamsb58112e2024-03-07 11:16:36 -060030PACKAGECONFIG[manpages] = "--enable-documentation, --disable-documentation, python3-sphinx-native python3-sphinx-rtd-theme-native"
Patrick Williamsac13d5f2023-11-24 18:59:46 -060031PACKAGECONFIG[programs] = "--enable-programs,--disable-programs"
32PACKAGECONFIG[convert] = "--enable-convert --with-convert=ext2,--disable-convert --without-convert,e2fsprogs"
33PACKAGECONFIG[zoned] = "--enable-zoned,--disable-zoned"
34PACKAGECONFIG[python] = "--enable-python,--disable-python,python3-setuptools-native"
35PACKAGECONFIG[lzo] = "--enable-lzo,--disable-lzo,lzo"
36PACKAGECONFIG[zstd] = "--enable-zstd,--disable-zstd,zstd"
37PACKAGECONFIG[udev] = "--enable-libudev,--disable-libudev,udev"
38
39# Pick only one crypto provider
40PACKAGECONFIG[crypto-builtin] = "--with-crypto=builtin"
41PACKAGECONFIG[crypto-libgcrypt] = "--with-crypto=libgcrypt,,libgcrypt"
42PACKAGECONFIG[crypto-libsodium] = "--with-crypto=libsodium,,libsodium"
43PACKAGECONFIG[crypto-libkcapi] = "--with-crypto=libkcapi,,libkcapi"
44
45inherit autotools-brokensep pkgconfig manpages
Patrick Williams56b44a92024-01-19 08:49:29 -060046inherit_defer ${@bb.utils.contains('PACKAGECONFIG', 'python', 'setuptools3-base', '', d)}
Patrick Williamsac13d5f2023-11-24 18:59:46 -060047
48CLEANBROKEN = "1"
49
50EXTRA_OECONF = "--enable-largefile"
51EXTRA_OECONF:append:libc-musl = " --disable-backtrace "
52EXTRA_PYTHON_CFLAGS = "${DEBUG_PREFIX_MAP}"
53EXTRA_PYTHON_CFLAGS:class-native = ""
54EXTRA_PYTHON_LDFLAGS = "${LDFLAGS}"
55EXTRA_OEMAKE = "V=1 'EXTRA_PYTHON_CFLAGS=${EXTRA_PYTHON_CFLAGS}' 'EXTRA_PYTHON_LDFLAGS=${EXTRA_PYTHON_LDFLAGS}'"
56
57do_configure:prepend() {
58 # Upstream doesn't ship this and autoreconf won't install it as automake isn't used.
59 mkdir -p ${S}/config
60 cp -f $(automake --print-libdir)/install-sh ${S}/config/
61}
62
63
64do_install:append() {
65 if [ "${@bb.utils.filter('PACKAGECONFIG', 'python', d)}" ]; then
66 oe_runmake 'DESTDIR=${D}' 'PYTHON_SITEPACKAGES_DIR=${PYTHON_SITEPACKAGES_DIR}' install_python
67 fi
68}
69
70RDEPENDS:${PN} = "libgcc"
71
72BBCLASSEXTEND = "native nativesdk"