blob: 0f091bbd7d740844a83c0721a6e455157da9acc5 [file] [log] [blame]
Andrew Geisslerc5535c92023-01-27 16:10:19 -06001SUMMARY = "Linux man-pages"
2DESCRIPTION = "The Linux man-pages project documents the Linux kernel and C library interfaces that are employed by user programs"
3SECTION = "console/utils"
4HOMEPAGE = "http://www.kernel.org/pub/linux/docs/man-pages"
5LICENSE = "GPL-2.0-or-later & GPL-2.0-only & GPL-1.0-or-later & BSD-2-Clause & BSD-3-Clause & BSD-4-Clause & MIT"
6
Patrick Williamsb58112e2024-03-07 11:16:36 -06007LIC_FILES_CHKSUM = "file://README;md5=72cff06b7954222c24d38bc2c41b234e \
8 file://LICENSES/BSD-2-Clause.txt;md5=9e16594a228301089d759b4f178db91f \
9 file://LICENSES/BSD-3-Clause.txt;md5=407426fcc1a243b7b2eff6e35c56aca9 \
Andrew Geisslerc5535c92023-01-27 16:10:19 -060010 file://LICENSES/BSD-4-Clause-UC.txt;md5=1da3cf8ad50cd8d5d1de3cfc53196d01 \
11 file://LICENSES/GPL-1.0-or-later.txt;md5=e5b7c80002ef72ab868b43ce47b65125 \
12 file://LICENSES/GPL-2.0-only.txt;md5=3d26203303a722dedc6bf909d95ba815 \
13 file://LICENSES/GPL-2.0-or-later.txt;md5=3d26203303a722dedc6bf909d95ba815 \
Patrick Williamsb58112e2024-03-07 11:16:36 -060014 file://LICENSES/Linux-man-pages-1-para.txt;md5=97ab07585ce6700273bc66461bf46bf2 \
15 file://LICENSES/Linux-man-pages-copyleft-2-para.txt;md5=1cafc230857da5e43f3d509c425d3c64 \
Andrew Geisslerc5535c92023-01-27 16:10:19 -060016 file://LICENSES/Linux-man-pages-copyleft.txt;md5=173b960c686ff2d26f043ddaeb63f6ce \
Patrick Williamsb58112e2024-03-07 11:16:36 -060017 file://LICENSES/Linux-man-pages-copyleft-var.txt;md5=d33708712c5918521f47f23b0c4e0d20 \
Andrew Geisslerc5535c92023-01-27 16:10:19 -060018 file://LICENSES/MIT.txt;md5=7dda4e90ded66ab88b86f76169f28663 \
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060019 "
Patrick Williamsb58112e2024-03-07 11:16:36 -060020SRC_URI = "${KERNELORG_MIRROR}/linux/docs/${BPN}/${BP}.tar.gz \
21 file://0001-man.ml-do-not-use-dev-stdin.patch \
Patrick Williams03514f12024-04-05 07:04:11 -050022 file://0001-GNUmakefile-use-env-from-PATH.patch \
Patrick Williamsb58112e2024-03-07 11:16:36 -060023 "
Andrew Geisslerc5535c92023-01-27 16:10:19 -060024
Patrick Williamsb58112e2024-03-07 11:16:36 -060025SRC_URI[sha256sum] = "006906e7be81a71c2d347809597bcb91485fa7fa488acdaa79e681ddfa894568"
Andrew Geisslerc5535c92023-01-27 16:10:19 -060026
27inherit manpages
28
Patrick Williams03514f12024-04-05 07:04:11 -050029# can be dropped when ubuntu 18.04 is not in use anymore
30DEPENDS += "coreutils-native"
31
Andrew Geisslerc5535c92023-01-27 16:10:19 -060032MAN_PKG = "${PN}"
33
34PACKAGECONFIG ??= ""
35PACKAGECONFIG[manpages] = ""
36
37do_configure[noexec] = "1"
38do_compile[noexec] = "1"
39
40do_install() {
41 oe_runmake install prefix=${prefix} DESTDIR=${D}
Patrick Williams169d7bc2024-01-05 11:33:25 -060042 rm -rf ${D}${mandir}/man3/crypt.3
43 rm -rf ${D}${mandir}/man3/crypt_r.3
44 rm -rf ${D}${mandir}/man3/getspnam.3
45 rm -rf ${D}${mandir}/man5/passwd.5
Andrew Geisslerc5535c92023-01-27 16:10:19 -060046}
47
48# Only deliveres man-pages so FILES:${PN} gets everything
49FILES:${PN}-doc = ""
50FILES:${PN} = "${mandir}/*"