Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | SUMMARY = "Text shaping library" |
| 2 | DESCRIPTION = "HarfBuzz is an OpenType text shaping engine." |
| 3 | HOMEPAGE = "http://www.freedesktop.org/wiki/Software/HarfBuzz" |
| 4 | BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=HarfBuzz" |
| 5 | SECTION = "libs" |
| 6 | LICENSE = "MIT" |
| 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=b98429b8e8e3c2a67cfef01e99e4893d \ |
| 8 | file://src/hb-ucd.cc;beginline=1;endline=15;md5=29d4dcb6410429195df67efe3382d8bc \ |
| 9 | " |
| 10 | |
| 11 | SRC_URI = "${GITHUB_BASE_URI}/download/${PV}/${BPN}-${PV}.tar.xz" |
Patrick Williams | 44b3caf | 2024-04-12 16:51:14 -0500 | [diff] [blame] | 12 | SRC_URI[sha256sum] = "f73e1eacd7e2ffae687bc3f056bb0c705b7a05aee86337686e09da8fc1c2030c" |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 13 | |
| 14 | DEPENDS += "glib-2.0-native" |
| 15 | |
| 16 | inherit meson pkgconfig lib_package gtk-doc gobject-introspection github-releases |
| 17 | |
| 18 | GIR_MESON_ENABLE_FLAG = 'enabled' |
| 19 | GIR_MESON_DISABLE_FLAG = 'disabled' |
| 20 | GTKDOC_MESON_ENABLE_FLAG = 'enabled' |
| 21 | GTKDOC_MESON_DISABLE_FLAG = 'disabled' |
| 22 | |
| 23 | PACKAGECONFIG ??= "cairo freetype glib icu" |
| 24 | PACKAGECONFIG[cairo] = "-Dcairo=enabled,-Dcairo=disabled,cairo" |
| 25 | PACKAGECONFIG[chafa] = "-Dchafa=enabled,-Dchafa=disabled,chafa" |
| 26 | PACKAGECONFIG[freetype] = "-Dfreetype=enabled,-Dfreetype=disabled,freetype" |
| 27 | PACKAGECONFIG[glib] = "-Dglib=enabled,-Dglib=disabled,glib-2.0" |
| 28 | PACKAGECONFIG[graphite] = "-Dgraphite2=enabled,-Dgraphite2=disabled,graphite2" |
| 29 | PACKAGECONFIG[icu] = "-Dicu=enabled,-Dicu=disabled,icu" |
| 30 | |
| 31 | PACKAGES =+ "${PN}-icu ${PN}-icu-dev ${PN}-subset" |
| 32 | |
| 33 | LEAD_SONAME = "libharfbuzz.so" |
| 34 | |
| 35 | do_install:append() { |
| 36 | # If no tools are installed due to PACKAGECONFIG then this directory might |
| 37 | # still be installed, so remove it to stop packaging warnings. |
| 38 | [ ! -d ${D}${bindir} ] || rmdir --ignore-fail-on-non-empty ${D}${bindir} |
| 39 | } |
| 40 | |
| 41 | FILES:${PN}-icu = "${libdir}/libharfbuzz-icu.so.*" |
| 42 | FILES:${PN}-icu-dev = "${libdir}/libharfbuzz-icu.la \ |
| 43 | ${libdir}/libharfbuzz-icu.so \ |
| 44 | ${libdir}/pkgconfig/harfbuzz-icu.pc \ |
| 45 | " |
| 46 | FILES:${PN}-subset = "${libdir}/libharfbuzz-subset.so.*" |
| 47 | |
| 48 | BBCLASSEXTEND = "native nativesdk" |