Chau Ly | b6eaef4 | 2023-10-18 14:02:04 +0000 | [diff] [blame^] | 1 | FILESEXTRAPATHS:append := "${THISDIR}/${PN}:" |
| 2 | RDEPENDS:${PN} += "bash" |
| 3 | |
| 4 | CONSOLE_CLIENT_SERVICE_FMT = "obmc-console-ssh@{0}.service" |
| 5 | CONSOLE_SERVER_CONF_FMT = "file://server.{0}.conf" |
| 6 | CONSOLE_CLIENT_CONF_FMT = "file://client.{0}.conf" |
| 7 | |
| 8 | SRC_URI += " \ |
| 9 | file://ampere_uartmux_ctrl.sh \ |
| 10 | file://obmc-console@.service \ |
| 11 | " |
| 12 | |
| 13 | SYSTEMD_SERVICE:${PN}:remove = "obmc-console-ssh.socket" |
| 14 | |
| 15 | FILES:${PN}:remove = "${systemd_system_unitdir}/obmc-console-ssh@.service.d/use-socket.conf" |
| 16 | |
| 17 | PACKAGECONFIG:append = " concurrent-servers" |
| 18 | |
| 19 | do_install:append() { |
| 20 | # Script to switch host's uart muxes by GPIOs |
| 21 | install -d ${D}${sbindir} |
| 22 | install -m 0755 ${WORKDIR}/ampere_uartmux_ctrl.sh ${D}/${sbindir} |
| 23 | |
| 24 | # Overriding service to call ampere_uart_console_setup.sh at ExecStartPre |
| 25 | install -d ${D}${systemd_system_unitdir} |
| 26 | install -m 0644 ${WORKDIR}/obmc-console@.service ${D}${systemd_system_unitdir} |
| 27 | } |