blob: aaf3525ad8cf3915d370e805d28f3d08642714ea [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "Enchant Spell checker API Library"
2DESCRIPTION = "A library (and command-line program) that wraps a number of \
3different spelling libraries and programs with a consistent interface."
4SECTION = "libs"
5HOMEPAGE = "https://abiword.github.io/enchant/"
6BUGTRACKER = "https://github.com/AbiWord/enchant/issues/"
7LICENSE = "LGPL-2.1-or-later"
8LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c"
9
10DEPENDS = "glib-2.0 groff-native"
11
12inherit autotools pkgconfig github-releases
13
14SRC_URI = "${GITHUB_BASE_URI}/download/v${PV}/enchant-${PV}.tar.gz"
Patrick Williams44b3caf2024-04-12 16:51:14 -050015SRC_URI[sha256sum] = "d9a5a10dc9b38a43b3a0fa22c76ed6ebb7e09eb535aff62954afcdbd40efff6b"
Patrick Williamsac13d5f2023-11-24 18:59:46 -060016
17GITHUB_BASE_URI = "https://github.com/AbiWord/enchant/releases"
18
19S = "${WORKDIR}/enchant-${PV}"
20
Patrick Williamsac13d5f2023-11-24 18:59:46 -060021PACKAGECONFIG ??= "aspell"
22PACKAGECONFIG[aspell] = "--with-aspell,--without-aspell,aspell,aspell"
23PACKAGECONFIG[hunspell] = "--with-hunspell,--without-hunspell,hunspell,hunspell"
24
25FILES:${PN} += " \
26 ${datadir}/enchant-2 \
27 ${libdir}/enchant-2 \
28"
29FILES:${PN}-staticdev += "${libdir}/enchant-2/*.a"