blob: e35bce7f3c30c824db2ee4116f0b88257e0a22ec [file] [log] [blame]
Andrew Geissler89770b02020-06-13 10:40:47 -05001SUMMARY = "C++ framework for implementing distributed and networked applications"
2DESCRIPTION = "C++ network programming framework that implements many core \
3patterns for concurrent communication software"
4LICENSE = "ACE-TAO-CIAO"
5HOMEPAGE = "http://www.dre.vanderbilt.edu/~schmidt/ACE.html"
6LIC_FILES_CHKSUM = "file://COPYING;md5=96ef88a5529594698e8ceabdd47df92c"
7
8DEPENDS += "openssl gperf-native"
9
10SRC_URI = "https://github.com/DOCGroup/ACE_TAO/releases/download/ACE%2BTAO-6_5_8/ACE-${PV}.tar.bz2 \
11 file://ace_config.patch \
12 "
13
14SRC_URI[md5sum] = "a6ba6a944612fe0696c90cbb5c3078ee"
15SRC_URI[sha256sum] = "cda2a960dbb9970a907663627711b2e2b14b3484a2859ae936370bcad0b16923"
16
17COMPATIBLE_HOST_libc-musl = "null"
18
19S = "${WORKDIR}/ACE_wrappers"
20B = "${WORKDIR}/ACE_wrappers/ace"
21export ACE_ROOT="${WORKDIR}/ACE_wrappers"
22
23inherit pkgconfig
24
25CXXFLAGS_append = " -fpermissive -Wnodeprecated-declarations"
26
Andrew Geisslerc87764f2020-06-27 00:16:32 -050027EXTRA_OEMAKE += "INSTALL_LIB=${baselib}"
28
Andrew Geissler89770b02020-06-13 10:40:47 -050029do_install() {
30 export D="${D}"
31 oe_runmake install
32
33 for i in $(find ${D} -name "*.pc") ; do
34 sed -i -e s:${D}::g \
35 -e s:/${TARGET_SYS}::g \
36 $i
37 done
38
39 rm -r ${D}/usr/share
40}
41
42UPSTREAM_CHECK_URI = "https://github.com/DOCGroup/ACE_TAO/releases"