Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | DESCRIPTION = "\ |
| 2 | IPC::Run allows you run and interact with child processes \ |
| 3 | using files, pipes, and pseudo-ttys. Both system()-style and scripted \ |
| 4 | usages are supported and may be mixed. Likewise, functional and OO API \ |
| 5 | styles are both supported and may be mixed." |
| 6 | HOMEPAGE = "https://metacpan.org/release/IPC-Run" |
| 7 | SECTION = "libs" |
| 8 | LICENSE = "Artistic-1.0 | GPL-1.0+" |
| 9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=0ebd37caf53781e8b7223e6b99b63f4e" |
| 10 | DEPENDS = "perl" |
| 11 | |
| 12 | SRC_URI = "git://github.com/toddr/IPC-Run.git" |
| 13 | SRCREV = "0b409702490729eeb97ae65f5b94d949ec083134" |
| 14 | |
| 15 | S = "${WORKDIR}/git" |
| 16 | |
| 17 | inherit cpan |
| 18 | |
| 19 | EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}" |
| 20 | |
| 21 | do_compile() { |
| 22 | export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')" |
| 23 | cpan_do_compile |
| 24 | } |