Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "Application to verify operation of serial ports" |
| 2 | HOMEPAGE = "http://git.breakpoint.cc/cgit/bigeasy/serialcheck.git/" |
| 3 | LICENSE = "GPLv2" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 5 | |
| 6 | SRC_URI = "git://git.breakpoint.cc/bigeasy/serialcheck.git \ |
| 7 | file://0001-Add-option-to-enable-internal-loopback.patch \ |
| 8 | file://0002-Restore-original-loopback-config.patch \ |
| 9 | file://0001-Makefile-Change-order-of-link-flags.patch \ |
| 10 | " |
| 11 | |
| 12 | SRCREV = "63854a2d0c0129efab132ec328a75279e013fb84" |
| 13 | |
| 14 | S = "${WORKDIR}/git" |
| 15 | |
| 16 | DEPENDS_append_libc-musl = " argp-standalone" |
| 17 | EXTRA_OEMAKE = "-e MAKEFLAGS=" |
| 18 | |
| 19 | CFLAGS_prepend = "-Wall -Wextra -Wno-sign-compare -Wno-pointer-sign " |
| 20 | LDFLAGS_append_libc-musl = " -largp" |
| 21 | |
| 22 | do_install() { |
| 23 | install -d ${D}${bindir} |
| 24 | install ${S}/serialcheck ${D}${bindir} |
| 25 | install -d ${D}${docdir}/${BP} |
| 26 | install ${S}/Readme.txt ${D}${docdir}/${BP} |
| 27 | } |
| 28 | CLEANBROKEN = "1" |
| 29 | |
| 30 | BBCLASSEXTEND = "nativesdk" |