Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | SUMMARY = "Shows and sets processor power related values" |
| 2 | DESCRIPTION = "cpupower is a collection of tools to examine and tune power \ |
| 3 | saving related features of your processor." |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 4 | LICENSE = "GPL-2.0-only" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 5 | DEPENDS = "pciutils gettext-native" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 6 | PROVIDES = "virtual/cpupower" |
| 7 | |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 8 | inherit kernelsrc kernel-arch bash-completion |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 9 | |
| 10 | do_populate_lic[depends] += "virtual/kernel:do_patch" |
| 11 | |
| 12 | EXTRA_OEMAKE = "-C ${S}/tools/power/cpupower O=${B} CROSS=${TARGET_PREFIX} CC="${CC}" LD="${LD}" AR=${AR} ARCH=${ARCH}" |
| 13 | |
| 14 | do_configure[depends] += "virtual/kernel:do_shared_workdir" |
| 15 | |
| 16 | do_compile() { |
| 17 | oe_runmake |
| 18 | } |
| 19 | |
| 20 | do_install() { |
| 21 | oe_runmake DESTDIR=${D} install |
| 22 | # Do not ship headers |
| 23 | rm -rf ${D}${includedir} |
| 24 | chown -R root:root ${D} |
| 25 | } |
| 26 | |
| 27 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
| 28 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 29 | RDEPENDS:${PN} = "bash" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 30 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 31 | python do_package:prepend() { |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 32 | d.setVar('PKGV', d.getVar("KERNEL_VERSION").split("-")[0]) |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 33 | } |
| 34 | |
| 35 | B = "${WORKDIR}/${BPN}-${PV}" |