Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 1 | SUMMARY = "Python interface to the Raspberry Pi camera module" |
| 2 | DESCRIPTION = "This package provides a pure Python interface to the Raspberry Pi camera module for Python 2.7 (or above) or Python 3.2 (or above)." |
| 3 | HOMEPAGE = "https://github.com/waveform80/picamera" |
| 4 | |
| 5 | LICENSE = "BSD-3-Clause" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4de8aab427192e4a8322a71375d20e21" |
| 7 | |
| 8 | RDEPENDS:${PN} = "python3-numbers \ |
| 9 | python3-ctypes \ |
| 10 | python3-colorzero \ |
| 11 | picamera-libs \ |
| 12 | " |
| 13 | |
| 14 | SRC_URI = "git://git@github.com/waveform80/picamera.git;protocol=ssh;branch=master" |
| 15 | SRCREV = "7e4f1d379d698c44501fb84b886fadf3fc164b70" |
| 16 | |
| 17 | S = "${WORKDIR}/git" |
| 18 | |
| 19 | inherit setuptools3 |
| 20 | |
| 21 | COMPATIBLE_HOST = "null" |
| 22 | COMPATIBLE_HOST:rpi:libc-glibc = "(arm.*)-linux" |