Andrei Kartashev | 423d2cb | 2021-11-26 14:20:32 +0300 | [diff] [blame] | 1 | SUMMARY = "Apply default configuration from baseboard FRU" |
| 2 | DESCRIPTION = "Provide baseboard FRU EEPROM handlers to apply platform configuration on system boot" |
| 3 | |
| 4 | inherit systemd |
| 5 | |
| 6 | SYSTEMD_SERVICE:${PN} = " \ |
| 7 | baseboard-fru-handler.service \ |
| 8 | " |
| 9 | |
| 10 | RDEPENDS:${PN} = "bash u-boot-fw-utils" |
| 11 | S = "${WORKDIR}" |
| 12 | SRC_URI = " \ |
| 13 | file://baseboard-fru-handler.sh \ |
| 14 | file://baseboard-fru-handler.service \ |
| 15 | " |
| 16 | |
| 17 | LICENSE = "Apache-2.0" |
| 18 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
| 19 | |
| 20 | do_install() { |
| 21 | install -m 0755 ${S}/baseboard-fru-handler.sh -D -t ${D}${bindir} |
| 22 | install -m 0644 ${S}/baseboard-fru-handler.service -D -t ${D}${systemd_system_unitdir} |
| 23 | } |