Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 1 | # |
| 2 | # Copyright OpenEmbedded Contributors |
| 3 | # |
| 4 | # SPDX-License-Identifier: MIT |
| 5 | # |
| 6 | |
| 7 | python __anonymous () { |
| 8 | if d.getVar('PREFERRED_PROVIDER_virtual/kernel') == 'linux-dummy': |
| 9 | # copy part codes from kernel.bbclass |
| 10 | kname = d.getVar('KERNEL_PACKAGE_NAME') or "kernel" |
| 11 | |
| 12 | # set an empty package of kernel-devicetree |
| 13 | d.appendVar('PACKAGES', ' %s-devicetree' % kname) |
| 14 | d.setVar('ALLOW_EMPTY:%s-devicetree' % kname, '1') |
| 15 | |
| 16 | # Merge KERNEL_IMAGETYPE and KERNEL_ALT_IMAGETYPE into KERNEL_IMAGETYPES |
| 17 | type = d.getVar('KERNEL_IMAGETYPE') or "" |
| 18 | alttype = d.getVar('KERNEL_ALT_IMAGETYPE') or "" |
| 19 | types = d.getVar('KERNEL_IMAGETYPES') or "" |
| 20 | if type not in types.split(): |
| 21 | types = (type + ' ' + types).strip() |
| 22 | if alttype not in types.split(): |
| 23 | types = (alttype + ' ' + types).strip() |
| 24 | |
| 25 | # set empty packages of kernel-image-* |
| 26 | for type in types.split(): |
| 27 | typelower = type.lower() |
| 28 | d.appendVar('PACKAGES', ' %s-image-%s' % (kname, typelower)) |
| 29 | d.setVar('ALLOW_EMPTY:%s-image-%s' % (kname, typelower), '1') |
| 30 | } |
| 31 | |