Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | SUMMARY = "Text-based modem control and terminal emulation program" |
| 2 | HOMEPAGE = "https://salsa.debian.org/minicom-team/minicom" |
| 3 | DESCRIPTION = "Minicom is a text-based modem control and terminal emulation program for Unix-like operating systems" |
| 4 | SECTION = "console/network" |
| 5 | DEPENDS = "ncurses virtual/libiconv" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 6 | LICENSE = "GPL-2.0-or-later" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=420477abc567404debca0a2a1cb6b645 \ |
| 8 | file://src/minicom.h;beginline=1;endline=12;md5=a58838cb709f0db517f4e42730c49e81" |
| 9 | |
| 10 | SRC_URI = "${DEBIAN_MIRROR}/main/m/${BPN}/${BPN}_${PV}.orig.tar.bz2 \ |
| 11 | file://allow.to.disable.lockdev.patch \ |
| 12 | file://0001-fix-minicom-h-v-return-value-is-not-0.patch \ |
| 13 | " |
| 14 | |
| 15 | SRC_URI[sha256sum] = "38cea30913a20349326ff3f1763ee1512b7b41601c24f065f365e18e9db0beba" |
| 16 | |
| 17 | PACKAGECONFIG ??= "" |
| 18 | PACKAGECONFIG[lockdev] = "--enable-lockdev,--disable-lockdev,lockdev" |
| 19 | |
| 20 | inherit autotools gettext pkgconfig |
| 21 | |
| 22 | do_install() { |
| 23 | for d in doc extras man lib src; do make -C $d DESTDIR=${D} install; done |
| 24 | } |
| 25 | |
| 26 | RRECOMMENDS:${PN} += "lrzsz" |
| 27 | |
| 28 | RDEPENDS:${PN} += "ncurses-terminfo-base" |