Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | SUMMARY = "Lightweight, desktop independent GTK+ archive manager" |
| 2 | HOMEPAGE = "http://xarchiver.sourceforge.net" |
| 3 | SECTION = "x11" |
| 4 | |
| 5 | LICENSE = "GPL-2.0-or-later" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 7 | |
| 8 | DEPENDS = "gtk+3 glib-2.0 xfce4-dev-tools-native intltool-native" |
| 9 | |
| 10 | SRC_URI = "git://github.com/ib/xarchiver.git;branch=master;protocol=https" |
| 11 | SRCREV = "55f923ebc623bcc8f53368543847350a23688189" |
| 12 | |
| 13 | S = "${WORKDIR}/git" |
| 14 | |
| 15 | inherit gettext pkgconfig autotools gtk-icon-cache features_check mime-xdg |
| 16 | |
| 17 | REQUIRED_DISTRO_FEATURES = "x11" |
| 18 | |
| 19 | # install tap files for thunar-archive-plugin in ${libdir}/thunar-archive-plugin |
| 20 | EXTRA_OECONF += "--libexecdir=${libdir}" |
| 21 | |
| 22 | EXTRA_OECONF += " \ |
| 23 | --enable-maintainer-mode \ |
| 24 | --disable-doc \ |
| 25 | " |
| 26 | |
| 27 | do_configure:prepend() { |
| 28 | touch ${S}/NEWS ${S}/AUTHORS |
| 29 | } |
| 30 | |
| 31 | FILES:${PN} += "${libdir}/thunar-archive-plugin" |
| 32 | |
| 33 | RRECOMMENDS:${PN} = "lzop zip tar bzip2 unzip xz p7zip" |