Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Enchant Spell checker API Library" |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 2 | DESCRIPTION = "A library (and command-line program) that wraps a number of \ |
| 3 | different spelling libraries and programs with a consistent interface." |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 4 | SECTION = "libs" |
| 5 | HOMEPAGE = "https://abiword.github.io/enchant/" |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 6 | BUGTRACKER = "https://github.com/AbiWord/enchant/issues/" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 7 | LICENSE = "LGPLv2.1+" |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 8 | LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 9 | |
| 10 | DEPENDS = "glib-2.0" |
| 11 | |
| 12 | inherit autotools pkgconfig |
| 13 | |
| 14 | SRC_URI = "https://github.com/AbiWord/enchant/releases/download/v${PV}/enchant-${PV}.tar.gz" |
Andrew Geissler | d159c7f | 2021-09-02 21:05:58 -0500 | [diff] [blame] | 15 | SRC_URI[sha256sum] = "7b4b1afcf2cd8bfa691deea6188404d337f23174bbc39b9c2add2bf340736e9c" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 16 | |
| 17 | UPSTREAM_CHECK_URI = "https://github.com/AbiWord/enchant/releases" |
| 18 | |
| 19 | S = "${WORKDIR}/enchant-${PV}" |
| 20 | |
| 21 | EXTRA_OEMAKE = "pkgdatadir=${datadir}/enchant-2" |
| 22 | |
| 23 | PACKAGECONFIG ??= "aspell" |
| 24 | PACKAGECONFIG[aspell] = "--with-aspell,--without-aspell,aspell,aspell" |
| 25 | PACKAGECONFIG[hunspell] = "--with-hunspell,--without-hunspell,hunspell,hunspell" |
| 26 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 27 | FILES:${PN} += " \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 28 | ${datadir}/enchant-2 \ |
| 29 | ${libdir}/enchant-2 \ |
| 30 | " |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 31 | FILES:${PN}-staticdev += "${libdir}/enchant-2/*.a" |