Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "Grilo is a framework forsearching media content from various sources" |
| 2 | LICENSE = "LGPL-2.1-only" |
| 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24" |
| 4 | |
| 5 | DEPENDS = " \ |
| 6 | libxml2 \ |
| 7 | glib-2.0 \ |
| 8 | " |
| 9 | |
| 10 | GNOMEBASEBUILDCLASS = "meson" |
| 11 | |
| 12 | inherit gnomebase gobject-introspection gtk-doc gettext vala |
| 13 | |
Patrick Williams | e760df8 | 2023-05-26 11:10:49 -0500 | [diff] [blame] | 14 | SRC_URI[archive.sha256sum] = "884580e8c5ece280df23aa63ff5234b7d48988a404df7d6bfccd1e77b473bd96" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 15 | |
| 16 | GIR_MESON_OPTION = "enable-introspection" |
| 17 | GTKDOC_MESON_OPTION = "enable-gtk-doc" |
| 18 | |
| 19 | # Note: removing 'net' from PACKAGECONFIG causes |
| 20 | # | bindings/vala/meson.build:15:0: ERROR: Unknown variable "grlnet_gir". |
| 21 | PACKAGECONFIG ??= "net" |
| 22 | |
| 23 | PACKAGECONFIG[net] = "-Denable-grl-net=true, -Denable-grl-net=false, libsoup-3.0" |
| 24 | PACKAGECONFIG[test-ui] = "-Denable-test-ui=true, -Denable-test-ui=false, gtk+3 liboauth" |
| 25 | |
| 26 | # Once we have a recipe for 'totem-plparser' this can turn into a PACKAGECONFIG |
| 27 | EXTRA_OEMESON = "-Denable-grl-pls=false" |
| 28 | |
Patrick Williams | 8e7b46e | 2023-05-01 14:19:06 -0500 | [diff] [blame] | 29 | do_compile:append() { |
| 30 | sed -i -e 's,${B}/../,,' ${B}/src/grl-type-builtins.h |
| 31 | } |