Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 1 | SUMMARY = "user and group account administration library" |
| 2 | DESCRIPTION = "The libuser library implements a standardized interface for manipulating and administering user \ |
| 3 | and group accounts" |
| 4 | HOMEPAGE = "https://pagure.io/libuser" |
| 5 | BUGTRACKER = "https://pagure.io/libuser/issues" |
| 6 | |
| 7 | LICENSE = "LGPL-2.0-only" |
| 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2 \ |
| 9 | file://lib/user.h;endline=19;md5=76b301f63c39fa992062395efbdc9558 \ |
| 10 | file://samples/testuser.c;endline=19;md5=3b87fa660fa3f4a6bb31d624afe30ba1" |
| 11 | |
| 12 | SECTION = "base" |
| 13 | |
Andrew Geissler | fc113ea | 2023-03-31 09:59:46 -0500 | [diff] [blame] | 14 | SRC_URI = "https://releases.pagure.org/libuser/libuser-${PV}.tar.gz \ |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 15 | file://0001-docs-Disable-building.patch \ |
| 16 | file://0002-remove-unused-execinfo.h.patch \ |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 17 | " |
| 18 | |
Andrew Geissler | fc113ea | 2023-03-31 09:59:46 -0500 | [diff] [blame] | 19 | SRC_URI[sha256sum] = "ea6094c72cb9e60a42fb53509dc98d124a340f1c9222783b503208adc16a0a8f" |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 20 | |
| 21 | DEPENDS = "bison-native popt libpam glib-2.0 python3" |
| 22 | |
| 23 | inherit autotools features_check gettext python3native python3-dir pkgconfig gtk-doc |
| 24 | |
| 25 | REQUIRED_DISTRO_FEATURES = "pam" |
| 26 | |
| 27 | EXTRA_OEMAKE = "PYTHON_CPPFLAGS=-I${STAGING_INCDIR}/${PYTHON_DIR}${PYTHON_ABI}" |
| 28 | |
| 29 | GTKDOC_DOCDIR = "${S}/docs/reference" |
| 30 | |
| 31 | # run autopoint since it needs ABOUT-NLS and admin/config.rpath from gettext |
| 32 | #EXTRA_AUTORECONF:remove = "--exclude=autopoint" |
| 33 | |
| 34 | do_configure:prepend() { |
| 35 | install -d ${S}/admin -d ${S}/m4 |
| 36 | touch ${S}/ABOUT-NLS ${S}/admin/config.rpath |
| 37 | cd ${S} |
| 38 | bison lib/getdate.y -o lib/getdate.c |
| 39 | cd - |
| 40 | } |
| 41 | |
| 42 | PACKAGES += "${PN}-python " |
| 43 | |
| 44 | FILES:${PN}-python = "${PYTHON_SITEPACKAGES_DIR}" |
| 45 | |