Andrew Geissler | e231d58 | 2020-05-05 08:53:09 -0500 | [diff] [blame] | 1 | SUMMARY = "A partition editor to graphically manage disk partitions " |
| 2 | HOMEPAGE = "http://gparted.org/index.php" |
| 3 | LICENSE = "GPLv2" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" |
| 5 | |
| 6 | inherit features_check autotools pkgconfig python3native gnome-help gtk-icon-cache |
| 7 | |
| 8 | REQUIRED_DISTRO_FEATURES = "x11" |
| 9 | |
| 10 | SRC_URI = " \ |
| 11 | ${SOURCEFORGE_MIRROR}/project/${BPN}/${BPN}/${BPN}-${PV}/${BPN}-${PV}.tar.gz \ |
| 12 | file://0001-Install-polkit-action-unconditionally-executable-pke.patch \ |
| 13 | " |
William A. Kennington III | b95905d | 2021-06-02 12:40:56 -0700 | [diff] [blame^] | 14 | SRC_URI[sha256sum] = "8dc180245dd9ea45e6e2f4bc69512f187e08be7f799c98a825a0b04c161cbd2a" |
Andrew Geissler | e231d58 | 2020-05-05 08:53:09 -0500 | [diff] [blame] | 15 | |
| 16 | DEPENDS += " \ |
| 17 | glib-2.0-native \ |
| 18 | yelp-tools-native \ |
| 19 | intltool-native \ |
| 20 | glib-2.0 \ |
| 21 | gtkmm3 \ |
| 22 | parted \ |
| 23 | " |
| 24 | |
| 25 | FILES_${PN} += " \ |
| 26 | ${datadir}/appdata \ |
| 27 | ${datadir}/icons \ |
| 28 | " |
| 29 | |
| 30 | PACKAGES += "${PN}-polkit" |
| 31 | FILES_${PN}-polkit = "${datadir}/polkit-1" |
| 32 | |
| 33 | RDEPENDS_${PN} = " \ |
| 34 | ${@bb.utils.contains('DISTRO_FEATURES', 'polkit', '${PN}-polkit', '', d)} \ |
| 35 | dosfstools \ |
| 36 | mtools \ |
| 37 | e2fsprogs \ |
| 38 | " |