Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "U-Boot bootloader image creation tool" |
| 2 | LICENSE = "GPLv2+" |
| 3 | LIC_FILES_CHKSUM = "file://Licenses/README;md5=0507cd7da8e7ad6d6701926ec9b84c95" |
| 4 | SECTION = "bootloader" |
| 5 | |
| 6 | DEPENDS = "openssl" |
| 7 | |
| 8 | # This revision corresponds to the tag "v2015.07" |
| 9 | # We use the revision in order to avoid having to fetch it from the |
| 10 | # repo during parse |
| 11 | SRCREV = "33711bdd4a4dce942fb5ae85a68899a8357bdd94" |
| 12 | |
| 13 | PV = "v2015.07+git${SRCPV}" |
| 14 | |
| 15 | SRC_URI = "git://git.denx.de/u-boot.git;branch=master" |
| 16 | |
| 17 | S = "${WORKDIR}/git" |
| 18 | |
| 19 | EXTRA_OEMAKE = 'CROSS_COMPILE="${TARGET_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" STRIP=true V=1' |
| 20 | |
| 21 | do_compile () { |
| 22 | oe_runmake sandbox_defconfig |
| 23 | oe_runmake cross_tools NO_SDL=1 |
| 24 | } |
| 25 | |
| 26 | do_install () { |
| 27 | install -d ${D}${bindir} |
| 28 | install -m 0755 tools/mkimage ${D}${bindir}/uboot-mkimage |
| 29 | ln -sf uboot-mkimage ${D}${bindir}/mkimage |
| 30 | } |
| 31 | |
| 32 | BBCLASSEXTEND = "native nativesdk" |